Bug 1795625 - Worker nodes have only one CPU
Summary: Worker nodes have only one CPU
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.0
Assignee: Roy Golan
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-28 13:54 UTC by Jan Zmeskal
Modified: 2020-05-04 11:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:27:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
worker (42.25 KB, image/png)
2020-01-28 13:54 UTC, Jan Zmeskal
no flags Details
master (40.89 KB, image/png)
2020-01-28 13:55 UTC, Jan Zmeskal
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3123 None closed Bug 1795625: ovirt's worker template is created with 1 CPU 2020-04-12 18:11:40 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:27:50 UTC

Description Jan Zmeskal 2020-01-28 13:54:17 UTC
Created attachment 1656018 [details]
worker

Description of problem:
When two worker nodes are created as part of IPI installation, they both have only one CPU (see attachment worker) as opposed to master nodes that have 4 logical CPUs (see attachment master). 

Version:
./openshift-install version
./openshift-install unreleased-master-2412-g96d416ee36d8660c3f2cb33863587455278f4ed2-dirty
built from commit 96d416ee36d8660c3f2cb33863587455278f4ed2
release image registry.svc.ci.openshift.org/ocp/release@sha256:d9656c774da7af205e0e8e218ea320560660edb5466c564bd41f3fe11b6f4244


How reproducible:
100 %

Steps to Reproduce:
1. Just perform OCP4 installation while not overriding any terraform variables

Actual results:
Worker nodes have 1 logical CPU

Expected results:
They should have 4 logical CPUs

Comment 1 Jan Zmeskal 2020-01-28 13:55:12 UTC
Created attachment 1656019 [details]
master

Comment 2 Jan Zmeskal 2020-01-28 14:06:31 UTC
One additional information: The template that gets created as a part of installation has also only one logical CPU.

Comment 3 Vishal Bhatia 2020-02-18 15:30:51 UTC
Created VMs are also reflected as type desktop in RHV, should be server

Comment 8 Jan Zmeskal 2020-02-20 08:57:02 UTC
Verified on:
quay.io/openshift-release-dev/ocp-release-nightly@sha256:94cdf5df7e61293f704adc7d5a92d62fbe9c69eda4ccdf09658d47775591c0b1
rhvm-4.3.8.2-0.1.master.el7.noarch

Comment 10 errata-xmlrpc 2020-05-04 11:27:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.