Bug 179563 - Fence configuration for DRAC doesn't support DRAC/MC, though fence_drac does
Fence configuration for DRAC doesn't support DRAC/MC, though fence_drac does
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 08:59 EST by Andrew C. Dingman
Modified: 2010-01-22 13:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 13:57:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew C. Dingman 2006-02-01 08:59:31 EST
Description of problem: fence_drac has support for the DRAC/MC in Dell 1855
blade chassis, but the system-config-cluster tool doesn't allow required
parameters to be set.


Version-Release number of selected component (if applicable): 1.0.16


How reproducible: Always


Steps to Reproduce:
1. Create a DRAC fence device
2. Add DRAC fence device to a fence level for a cluster node
3. Note that the dialog box says "DRAC Fencing (no parameters)"
4. Try to edit properties of the fence, in hopes that now you can make the
change. Note that the dialog box has not changed.
5. Read lines 566-570 of fence_drac, or simply realize that of course you have
to have at least one parameter to specify which blade to fence, since fencing
all ten nodes in a chassis probably has undesirable results in most configurations.
  
Actual results:
Can't specify which blade to fence. Reading fence_drac suggests that the result
will be a failed fence.

Expected results:
Drop-down or even a text box with which to specify which blade to fence. (The
correct solution depends on whether the server modules in the DRAC can be
re-named by the user. I've never tried.)

Additional info:
Manually adding a modulename attribute to the fence causes a plethora of errors
when re-starting system-config-cluster
Comment 2 Jim Parsons 2006-02-15 07:39:26 EST
This support will be present when U3 ships.
Comment 3 Lon Hohberger 2010-01-22 13:57:11 EST
This fix was included in Red Hat Cluster Suite 4, update 3 and later.

Note You need to log in before you can comment on or make changes to this bug.