Bug 1795658 - Operator registry package "pkg/configmap" takes unnecessary dependency on cgo package go-sqlite3
Summary: Operator registry package "pkg/configmap" takes unnecessary dependency on cgo...
Keywords:
Status: CLOSED DUPLICATE of bug 1796092
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Ben Luddy
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-28 15:10 UTC by Ben Luddy
Modified: 2020-02-06 03:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-04 17:13:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-registry pull 161 None closed Bug 1795658: Remove dependency on sqlite from pkg/configmap. 2020-02-03 10:41:29 UTC

Internal Links: 1796092

Description Ben Luddy 2020-01-28 15:10:05 UTC
The package github.com/mattn/go-sqlite3 needs CGO enabled to
build. Since pkg/configmap has both direct and transitive dependencies
on go-sqlite3, anything importing pkg/configmap will also need to
enable CGO. This affects importers of pkg/configmap that have disabled CGO.

Comment 3 Ben Luddy 2020-02-04 17:13:32 UTC
This bug is tracking the same problem as https://bugzilla.redhat.com/show_bug.cgi?id=1796092#c2, from the opposite direction. I'm marking this as a duplicate -- verification steps for the other bug are provided in the linked comment.

*** This bug has been marked as a duplicate of bug 1796092 ***


Note You need to log in before you can comment on or make changes to this bug.