Bug 179567 - Cannot delete normal users from the Satellite
Cannot delete normal users from the Satellite
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
400
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: James Slagle
Vlady Zlatkin
:
Depends On:
Blocks: 171832
  Show dependency treegraph
 
Reported: 2006-02-01 09:20 EST by Kent Baxley
Modified: 2007-07-31 11:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhn406
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 10:38:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from catalina.out (240.56 KB, application/octet-stream)
2006-02-01 09:22 EST, Kent Baxley
no flags Details
Traceback email from failure (8.77 KB, text/plain)
2006-02-01 18:21 EST, Kent Baxley
no flags Details

  None (edit)
Description Kent Baxley 2006-02-01 09:20:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The documentation for Satellite 4.0.5 states that you no longer have to disassociate the user with any roles in order to delete them.  The only exception now is the Organizational Admin.  

In testing this out on a Satellite Server here running the 4.0.5 code, I found that a normal user *still* cannot be deleted from the Satellite unless they are first disassociated from a system group, which is contradictory to what the documentation says.


Version-Release number of selected component (if applicable):
Satellite 4.x

How reproducible:
Always

Steps to Reproduce:
1. Log in to the Satellite WebUI as an Organizational Admin

2. Create a new user and associate that user with a system group

3. Try to delete the user from the webUI
  

Actual Results:  Any attempts at deleting the user result in the following error from the Web UI:

INTERNAL ERROR

"The server experienced a problem which prevented your request from
being filled out. It may not be possible to execute this action at this
time.

Please help us correct this problem by contacting us with details of how
you received this message."

I had to go back and disassociate the user from the system group before the Satellite let me delete the user.

Expected Results:  The user should have been deleted without having to disassociate it from the system group.

Additional info:

I have attached, for now, the /var/log/tomcat5/catalina.out file.  I also expect to get a traceback error message posted as well.

This is also been reproduced on another Satellite running version 4.0.1
Comment 1 Kent Baxley 2006-02-01 09:22:30 EST
Created attachment 123964 [details]
output from catalina.out

Output from /var/log/tomcat5/catalina.out attached.  Traceback output will be
posted later.
Comment 2 Kent Baxley 2006-02-01 18:21:13 EST
Created attachment 124015 [details]
Traceback email from failure

Traceback email attached
Comment 7 James Slagle 2006-03-03 10:36:40 EST
that exception would be caused by:

1. you're not on a satellite (not the case here)
2. there are no other org admins available (doesn't seem to be the case)
3. there is a row somewhere that's not getting cleaned up before deleting from
web-contact

Can we verify that the java code is doing what the perl code used to be doing in
the case?  I ask, b/c somethin similiar came up before, and the cause was that
the logic in the java code had changed from the perl days:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=156752
Comment 11 James Slagle 2006-04-10 15:27:23 EDT
I can't reprodue this bug following the steps from Kent.  Kent, can you provide
any additional info?

There haven't been any changes to the stored procedure.

Ryan, have you verified that the Java code is doing the exact same thing the
perl code was?
Comment 12 James Slagle 2006-04-10 15:30:28 EDT
sent Kent email directly asking if he has any more info.
Comment 14 James Slagle 2006-04-11 10:38:44 EDT
closing.  couldn't reproduce on 4.0.6

Note You need to log in before you can comment on or make changes to this bug.