Bug 1795671 - Nightly upgrade tuned pods couldn't be started [NEEDINFO]
Summary: Nightly upgrade tuned pods couldn't be started
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.2.z
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.2.z
Assignee: Sebastian Jug
QA Contact: Simon
URL:
Whiteboard: 4.2.19
Depends On: 1795665
Blocks: 1791916
TreeView+ depends on / blocked
 
Reported: 2020-01-28 15:39 UTC by Sebastian Jug
Modified: 2020-03-26 07:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-26 07:21:27 UTC
Target Upstream Version:
sdodson: needinfo? (sejug)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-node-tuning-operator pull 109 None closed Bug 1795671: Do not set owner references on tuned ServiceAccount (4.2) 2020-05-28 11:31:51 UTC
Red Hat Product Errata RHBA-2020:0826 None None None 2020-03-26 07:21:38 UTC

Description Sebastian Jug 2020-01-28 15:39:37 UTC
Description of problem:
A race condition exists in upgrades for node tuning operator


How reproducible:
Rare


Steps to Reproduce:
1. Upgrade OCP version
2. ???


Actual results:
Occasionally the tuned pods would have issues starting due to a race condition around the Service Account


Expected results:
Tuned should update along with the rest of the cluster operator and components

Comment 5 Simon 2020-03-16 14:24:20 UTC
Retest positive.
Upgrade 4.2.0-0.nightly-2020-03-09-194140 -> 4.2.0-0.nightly-2020-03-16-055952

Comment 7 errata-xmlrpc 2020-03-26 07:21:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0826


Note You need to log in before you can comment on or make changes to this bug.