Bug 1795776 - cluster-etcd-operator: bootstrap timeout CI fails without logs
Summary: cluster-etcd-operator: bootstrap timeout CI fails without logs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-28 20:32 UTC by Sam Batschelet
Modified: 2020-04-14 13:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-22 00:08:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3007 None closed Bug 1795776: data/bootstrap: delay the removal of bootstrap mcs 2020-04-13 20:57:28 UTC

Description Sam Batschelet 2020-01-28 20:32:07 UTC
Description of problem:

Since the merge of cluster-etcd-operator under certain circumstances the cluster will fail on timeout and no/minimal logs will be collected.

[1] https://gcsweb-ci.svc.ci.openshift.org/gcs/origin-ci-test/pr-logs/pull/openshift_installer/2998/pull-ci-openshift-installer-master-e2e-gcp/213/artifacts/e2e-gcp/


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: Cluster timeout reported no logs collected from CI run.


Expected results: Cluster bootstraps with timeout. If the cluster fails logs are collected.


Additional info:


Note You need to log in before you can comment on or make changes to this bug.