Bug 179580 - [PATCH] Add a --root/-r option to chkconfig/ntsysv
[PATCH] Add a --root/-r option to chkconfig/ntsysv
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: chkconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 10:36 EST by Olivier Galibert
Modified: 2014-03-16 22:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 11:51:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add --root option to chkconfig and ntsysv (20.13 KB, patch)
2006-02-01 10:38 EST, Olivier Galibert
no flags Details | Diff
Adds --root option and test script. (8.64 KB, patch)
2006-02-09 10:02 EST, John Fusco
no flags Details | Diff

  None (edit)
Description Olivier Galibert 2006-02-01 10:36:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.7.12-1.3.1

Description of problem:
chkconfig needs a --root option to manage the startup services in a system image used for in my case cluster installations.  Can be useful for nfsboot too I guess.


Version-Release number of selected component (if applicable):
chkconfig-1.3.25

How reproducible:
Always

Steps to Reproduce:
Not very adapted to sending in patches are we?

I guess "chkconfig needs an upstream" could be another bug entry...


Additional info:
Comment 1 Olivier Galibert 2006-02-01 10:38:15 EST
Created attachment 123966 [details]
Add --root option to chkconfig and ntsysv

Damn, bugwilla does suck for sending in patches...
Comment 2 Bill Nottingham 2006-02-01 23:03:19 EST
Why not run it with 'chroot ... chkconfig ...'?
Comment 3 Olivier Galibert 2006-02-02 12:05:31 EST
Hmmm, it works.  I don't like chroot much because it relies on having a fully
working system in the image while not having proc, dev and all mounted there,
but in the specific case of chkconfig it works.
Comment 4 John Fusco 2006-02-09 10:02:18 EST
Created attachment 124438 [details]
Adds --root option and test script.

Alternative implementation based on 1.3.26. Less invasive approach touches
fewer modules.

Also includes unit_test script for new --root option to chkconfig.

Needs translations and man page update.
Comment 5 Matthew Miller 2007-04-06 12:06:57 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 6 Jon Stanley 2008-05-10 02:26:02 EDT
chkconfig has yet to grow this functionality.  Bill, could you comment on
whether you think chkconfig *should* have this functionality, and either merge
the patch (which probably needs work by now), or close this bug?
Comment 7 Bill Nottingham 2008-05-12 11:51:30 EDT
My apologies for the delay. I do stand by comment #2; this is really better done
with chroot itself.

Note You need to log in before you can comment on or make changes to this bug.