Bug 1795919 - Link created for virtual device even if master is not present
Summary: Link created for virtual device even if master is not present
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-29 08:37 UTC by Beniamino Galvani
Modified: 2020-04-28 16:54 UTC (History)
10 users (show)

Fixed In Version: NetworkManager-1.22.6-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:11 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Reproducer (1.17 KB, application/x-shellscript)
2020-01-29 08:37 UTC, Beniamino Galvani
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:38 UTC

Description Beniamino Galvani 2020-01-29 08:37:35 UTC
Created attachment 1656185 [details]
Reproducer

If a connection for a virtual device is added and its master is not
present, NetworkManager creates the link without activating the
connection.

This bug was found by nmstate CI, where a VLAN enslaved to an ovs-port
was created even when the master was not present due to lack of the
NM-ovs plugin. Then NM failed to create another VLAN because the first
one already existed with the same id.

Reproducer script in attachment.

NM version: current git master

Comment 4 Vladimir Benes 2020-02-10 18:38:08 UTC
test case added:
bridge_no_link_till_master

Comment 6 errata-xmlrpc 2020-04-28 16:54:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.