Bug 1795957 - IPv6 RA timeout cannot be set higher than 120 secs
Summary: IPv6 RA timeout cannot be set higher than 120 secs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.0
Assignee: sushil kulkarni
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-29 10:24 UTC by Ales Musil
Modified: 2020-04-28 16:54 UTC (History)
12 users (show)

Fixed In Version: NetworkManager-1.22.6-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:14 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:36 UTC

Description Ales Musil 2020-01-29 10:24:14 UTC
Description of problem:

IPv6 RA timeout is derived from /proc/sys/net/ipv6/conf/$dev/router_solicitations * /proc/sys/net/ipv6/conf/$dev/router_solicitation_interval. But is clamped between 30 and 120 secs. 

Version-Release number of selected component (if applicable):
NetworkManager-1.22.0-2.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create dummy interface 
1. Set router_solicitations and router_solicitation_interval to 15 for the dummy
2. Enable RA via NetworkManager for the dummy


Actual results:
RA timeout is set for 120 secs

Expected results:
RA timeout 225

Additional info:

Comment 4 Beniamino Galvani 2020-01-31 12:47:01 UTC
(In reply to RHEL Program Management from comment #2)

> Answer the following 3 questions:
> 1. What is the scope of harm if this BZ is not resolved in this release? 
> Reviewers want to know which RHEL features or customers are affected and if
> it will impact any Layered Product or Hardware partner plans.

This bug badly impacts RHV as it breaks connectivity for VMs.

> 2. What are the risks associated with resolving this BZ?  Reviewers want to
> know the scope of retesting, potential regressions

The fix is simple and self-contained, it doesn't impact other parts of code except IPv6 RA. We have 900+ tests in CI that covers many features, including IPv6 RA, so the regression risk is very low.

> 3. Provide any other details that meet blocker criteria or should be weighed
> in making a decision (Other releases affected, upstream status, business
> impacts, etc).

The bug is already fixed upstream.

Comment 6 Vladimir Benes 2020-02-12 17:01:36 UTC
solicitation_period_prolonging test added

Comment 8 errata-xmlrpc 2020-04-28 16:54:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.