Bug 1796096 - oc adm catalog mirror does not work with image SHAs
Summary: oc adm catalog mirror does not work with image SHAs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.0
Assignee: Kevin Rizza
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks: 1796182
TreeView+ depends on / blocked
 
Reported: 2020-01-29 15:42 UTC by Jason Montleon
Modified: 2020-05-04 11:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1796182 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:27:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:27:45 UTC

Description Jason Montleon 2020-01-29 15:42:49 UTC
Description of problem:
Images listed in CSV's with SHAs do not appear to mirror correctly. We have 3 versions of our CSV in stage v1.0.0, v1.0.1, and v1.1.0.

v1.0.0 lists only the operator using a tag, v1.0.

v1.0.1 and v1.1.0 list the operator and operands using SHAs

The output of the oc adm catalog mirror command appears to show only one of our images across all three versions being properly mirrored.


Version-Release number of selected component (if applicable):
Client Version: openshift-clients-4.3


How reproducible:
Always

Comment 5 Kevin Rizza 2020-01-29 19:15:48 UTC

*** This bug has been marked as a duplicate of bug 1790798 ***

Comment 6 Kevin Rizza 2020-01-29 19:27:32 UTC
tested that this issues is already fixed in 4.4 via https://github.com/openshift/oc/pull/212

moving to MODIFIED for QE to confirm

Comment 7 Bruno Andrade 2020-01-30 15:16:38 UTC
Mirroring worked as expected on 4.4, marking as VERIFIED.

oc version                                                                                                                                                    
Client Version: 4.4.0-0.nightly-2020-01-29-175627
Server Version: 4.4.0-0.nightly-2020-01-29-175627
Kubernetes Version: v1.17.1

Steps used to reproduce:
http://pastebin.test.redhat.com/831838

Comment 9 errata-xmlrpc 2020-05-04 11:27:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.