Bug 1796116 - Tech Preview and Dev preview not shown in new search dropdown
Summary: Tech Preview and Dev preview not shown in new search dropdown
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-29 16:06 UTC by Zac Herman
Modified: 2020-05-04 11:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:27:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
verify pipeline page on dev console (200.70 KB, image/png)
2020-02-14 06:44 UTC, XiaochuanWang
no flags Details
verify monitoring page on dev console (212.16 KB, image/png)
2020-02-14 06:44 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4113 None closed Bug 1796116: Add Tech/Dev Preview in dropdown and expander 2020-04-17 17:49:43 UTC
Github openshift console pull 4256 None closed Bug 1796116: fix duplicate badge on dev console list pages 2020-04-17 17:49:43 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:27:45 UTC

Description Zac Herman 2020-01-29 16:06:49 UTC
Description of problem:
Resources that are in tech or dev preview should be labelled on the search page dropdown and results.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Go to search page, open resource dropdown, filter for Pipeline
2. Pipelines are in DEV preview and should have label
3.

Actual results:
Pipelines have no extra label

Expected results:
Pipelines should read: Pipelines - Dev Preview

Additional info:

Comment 3 XiaochuanWang 2020-02-03 05:38:05 UTC
Add a screenshot for dev-preview label. Search "pipeline" will show the filter result which has "Dev Preview" label in red font. When click one of the resource, filter list page will also show the "Dev Preview" in Red un-clickable label.

This could be Verified.
Tested on 4.4.0-0.nightly-2020-02-02-201619

Comment 4 Samuel Padgett 2020-02-07 20:07:55 UTC
Reopening since this caused duplicate badges to appear on normal list pages

Comment 6 XiaochuanWang 2020-02-14 06:44:06 UTC
Created attachment 1663054 [details]
verify pipeline page on dev console

Comment 7 XiaochuanWang 2020-02-14 06:44:42 UTC
Created attachment 1663055 [details]
verify monitoring page on dev console

Comment 8 XiaochuanWang 2020-02-14 06:47:46 UTC
This is fixed on Dev Console: https://github.com/openshift/console/pull/4256

Tested on latest version: 4.4.0-0.nightly-2020-02-13-212616
Checked on Pipeline page and Monitoring page, it's not reproduced, also attached the screenshots as above.
This could be Verified.

Comment 11 errata-xmlrpc 2020-05-04 11:27:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.