Bug 1796148 - [IPI][Baremetal]: Remove .template from path in dhcp-dhclient-conf.yaml
Summary: [IPI][Baremetal]: Remove .template from path in dhcp-dhclient-conf.yaml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Steven Hardy
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks: 1798170
TreeView+ depends on / blocked
 
Reported: 2020-01-29 17:33 UTC by Steven Hardy
Modified: 2020-05-04 11:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1798170 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:27:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1419 None closed Bug 1796148: baremetal: Remove .template from path in dhcp-dhclient-conf.yaml 2020-03-03 14:21:43 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:18 UTC

Description Steven Hardy 2020-01-29 17:33:21 UTC
Description of problem:

The worker template writes out the file as /etc/dhcp/dhclient.conf.template
with no subsequent render-config templating to create the actual
/etc/dhcp/dhclient.conf - this differs from the masters where we write out the dhclient.conf correctly.


How reproducible:
Always


Steps to Reproduce:
1. Deploy IPI baremetal environment with at least one worker
2. Observe the /etc/dhcp/dhclient.conf is not written with the "supersede domain-search" option pointing to the cluster domain


Actual results:

The expected file is written out as /etc/dhcp/dhclient.conf.template

Expected results:

/etc/dhcp/dhclient.conf should be written so it includes the domain-search option, and then the search entry in the resolv.conf will be correctly added.

Comment 2 Dan Winship 2020-02-11 15:39:20 UTC
cc: mcornea for possible QA; it looks like this IS legitimately testable in 4.4 even without working IPv6

Comment 3 Marius Cornea 2020-02-11 17:44:44 UTC
Verified on 4.4.0-0.nightly-2020-02-07-203942:

[root@worker-0 core]# cat /etc/dhcp/dhclient.conf 
supersede domain-search "ocp-edge-cluster.qe.lab.redhat.com";

Comment 5 errata-xmlrpc 2020-05-04 11:27:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.