Bug 1796150 - "Set Traffic Distribution" action on Service causes runtime error
Summary: "Set Traffic Distribution" action on Service causes runtime error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.4.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-29 17:39 UTC by Samuel Padgett
Modified: 2020-05-04 11:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Both knative Service and regular k8s service is of same kind "Service" so action meny/Kebeb option shows up for k8s Service which should only show for knative Service Consequence: "Set Traffic Distribution" action on Service causes runtime error Fix: Avoid check on kind directly and have made use of referenceForModel instead of directly checking for kind (it give apiGrouop~apiVersion~Kind which is unique) Result: Action menu works correctly for both knative Service as well as k8s Service
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-01-28-150858 Cluster ID: b91b6151-f75a-4bdd-901b-aad4537e7d2e Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0
Last Closed: 2020-05-04 11:27:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
Runtime error in console (429.41 KB, image/png)
2020-01-29 17:39 UTC, Samuel Padgett
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4150 None closed Bug 1796150: fixes traffic split menu option error on kebab for core service 2020-04-20 08:50:45 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:18 UTC

Description Samuel Padgett 2020-01-29 17:39:26 UTC
Created attachment 1656346 [details]
Runtime error in console

Steps to reproduce:

* Go to search view.
* Find a service. You should be able to reproduce with service console in openshift-console.
* Select "Set Traffic Distribution" from the kebab

Result:

You see a runtime error in the JS console.

TypeError: "resources.configurations is undefined"
    getKnativeServiceData knative-topology-utils.ts:103
    transformTrafficSplitingData traffic-splitting-utils.ts:29
    Controller TrafficSplittingController.tsx:22
    React 22
    result modal.tsx:25
    createModal modal.tsx:16
    createModalLauncher modal.tsx:62
    setTrafficDistributionModal index.ts:2

Comment 1 Andrew Ballantyne 2020-01-29 19:18:08 UTC
Added to the backlog https://issues.redhat.com/browse/ODC-2900

Comment 4 errata-xmlrpc 2020-05-04 11:27:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.