Bug 1796189 - Machine OS image URL should be included in the customized resource definition for consumption by the baremetal operator
Summary: Machine OS image URL should be included in the customized resource definition...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: All
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Stephen Benjamin
QA Contact: Shelly Miron
URL:
Whiteboard: Telco:Deployment
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-29 19:41 UTC by Ian Main
Modified: 2020-05-04 11:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:27:55 UTC
Target Upstream Version:
smiron: needinfo+


Attachments (Terms of Use)
oc describe metal3provisioning (74.77 KB, image/png)
2020-02-20 12:15 UTC, Shelly Miron
no flags Details
install_config.yaml (83.75 KB, image/png)
2020-02-20 12:36 UTC, Shelly Miron
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2987 None closed Bug 1796189: baremetal: Add the image URL to the baremetal CR 2020-04-27 06:48:22 UTC
Github openshift machine-api-operator pull 482 None closed Bug 1796189: Add support for image download url in the provisioning CRD 2020-04-27 06:48:22 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:18 UTC

Description Ian Main 2020-01-29 19:41:12 UTC
Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Ian Main 2020-01-29 19:45:49 UTC
Sorry, hit enter in a field and it submitted the bug.

Description of problem:

We've created a CRD to supply the MAO and ultimately the BMO with all the information it needs to perform baremetal deployments except the machine OS image.  We thought we could get this from elsewhere but it turns out we need it for our downloader container to work.  This would involve updating the CRD created by the BMO and the CR created in the installer to include a new MachineOSImageURL field.

Comment 4 Shelly Miron 2020-02-20 12:13:02 UTC
Hi, We added the 'ProvisioningOSDownloadURL' field in the install_config.yaml file with this image: http://192.168.123.1/rhcos-44.81.202001241431.0-openstack.x86_64.qcow2.gz
but after deploying, we ran the following command from the provisionhost: oc describe provisionings.metal3.io, and the image that showed up in 'ProvisioningOSDownloadURL'
is this one- https://releases-art-rhcos.svc.ci.openshift.org/art/storage/releases/rhcos-4.4/44.81.202001241431.0/x86_64/rhcos-44.81.202001241431.0-openstack.x86_64.qcow2.gz?sha256=03f713b1a63f942a09e33ef1038368cff40a56f77c71818a1323fc9949dbbffc instead

images attached below.

Comment 5 Shelly Miron 2020-02-20 12:15:34 UTC
Created attachment 1664330 [details]
oc describe metal3provisioning

Comment 6 Shelly Miron 2020-02-20 12:36:37 UTC
Created attachment 1664354 [details]
install_config.yaml

Comment 7 Stephen Benjamin 2020-02-20 13:05:55 UTC
ProvisioningOSDownloadURL is only a CR field, it's not something you can put in the install-config.yaml.  It is the location of the RHCOS image, which the installer knows but we needed a way to get it into the cluster. So, I would consider your test showing this is validated.  The URL in the CR was set.

If the user wants to override the images there's other fields in the install-config for that, but it's not part of this feature.

Comment 8 Shelly Miron 2020-02-24 14:57:04 UTC
Verified.
Bug was checked in OCP version 4.4 with ipv4 using 3 workers. 
Running the following command:  oc describe provisionings.metal3.io , to check this image -  https://releases-art-rhcos.svc.ci.openshift.org/art/storage/releases/rhcos-4.4/44.81.202001241431.0/x86_64/rhcos-44.81.202001241431.0-openstack.x86_64.qcow2.gz?sha256=03f713b1a63f942a09e33ef1038368cff40a56f77c71818a1323fc9949dbbffc appear in the cluster.

Comment 10 errata-xmlrpc 2020-05-04 11:27:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.