Bug 1796224 - python-pybeam fails to build: needs construct<2.10,>=2.9
Summary: python-pybeam fails to build: needs construct<2.10,>=2.9
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pybeam
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS PYTHON39
TreeView+ depends on / blocked
 
Reported: 2020-01-29 22:23 UTC by Miro Hrončok
Modified: 2020-02-15 10:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-15 10:47:57 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github matwey pybeam issues 11 None open Migrate to construct 2.10 2020-02-12 13:33:07 UTC
Github matwey pybeam pull 12 None open Support construct v2.10.x 2020-02-14 00:16:47 UTC

Description Miro Hrončok 2020-01-29 22:23:01 UTC
python-pybeam fails to build with Python 3.9.0a3. This is not related to Python 3.9, a test dependency is broken:

+ /usr/bin/python3 setup.py test
running test
WARNING: Testing via this command is deprecated and will be removed in a future version. Users looking for a generic test entry point independent of test runner are encouraged to use tox.
Searching for construct<2.10,>=2.9
Reading https://pypi.org/simple/construct/
Download error on https://pypi.org/simple/construct/: [Errno -2] Name or service not known -- Some packages may not be found!
Couldn't retrieve index page for 'construct'
Scanning index of all packages (this may take a while)
Reading https://pypi.org/simple/
Download error on https://pypi.org/simple/: [Errno -2] Name or service not known -- Some packages may not be found!
No local packages or working download links found for construct<2.10,>=2.9
error: Could not find suitable distribution for Requirement.parse('construct<2.10,>=2.9')


construct was updated:

https://src.fedoraproject.org/rpms/python-construct/c/4f0db92bfcf39aba21f20e7224e5aa53bffe3467?branch=master

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01199341-python-pybeam/

For all our attempts to build python-pybeam with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-pybeam/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2020-02-11 17:18:09 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 2 Neal Gompa 2020-02-12 13:34:09 UTC
This is currently broken in Rawhide and has broken rpmlint CI.

Error: 
 Problem: conflicting requests
  - nothing provides python3.8dist(construct) < 2.10 needed by python3-pybeam-0.5-4.fc32.noarch

Comment 3 Tomáš Chvátal 2020-02-12 16:52:42 UTC
It actually builds and tests are passing with new construct; the only change I had to do on openSUSE is:

# do not block the new python-construct
sed -i -e ',<2.10' setup.py

Comment 4 Neal Gompa 2020-02-14 00:16:48 UTC
Confirmed the same as well.


Sent PR upstream: https://github.com/matwey/pybeam/pull/12

Comment 5 Neal Gompa 2020-02-14 00:28:51 UTC
Submitted packaging PR to fix this in Fedora: https://src.fedoraproject.org/rpms/python-pybeam/pull-request/3

Comment 6 Neal Gompa 2020-02-14 12:39:34 UTC
The PR upstream has been merged, and upstream has issued version 0.6.

The packaging PR has been also merged, and new builds have been pushed into Fedora 32 and Rawhide to resolve this issue.

So I guess we're waiting for a Rawhide compose now?

Comment 7 Miro Hrončok 2020-02-14 13:28:55 UTC
The push to master has triggered a build: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/build/1239608/ -- but it failed because the Koji repo was not accessible for a while. It needs to be manually triggered again from the package page at https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-pybeam/ (any Python SIG member can do that).

Comment 8 Neal Gompa 2020-02-15 10:47:57 UTC
This issue is now completely resolved:

* Rawhide push: https://koji.fedoraproject.org/koji/buildinfo?buildID=1460916
* Fedora 32 push: https://koji.fedoraproject.org/koji/buildinfo?buildID=1460917
* Python 3.9 rebuild in COPR: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/build/1240662/


Note You need to log in before you can comment on or make changes to this bug.