Bug 1796234 - oc explain tests shouldn't be enabled for openshift-sdn crds on ovn
Summary: oc explain tests shouldn't be enabled for openshift-sdn crds on ovn
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.4.0
Assignee: Aniket Bhat
QA Contact: zhou ying
URL:
Whiteboard:
: 1796591 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-29 23:05 UTC by Aniket Bhat
Modified: 2020-05-04 11:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:27:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24477 None closed Bug 1796234: Move the oc explain tests for networking CRDs to a new test 2020-02-03 03:58:58 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:18 UTC

Description Aniket Bhat 2020-01-29 23:05:16 UTC
Description of problem:

oc explain tests that validated the openapiv3 schema were added for the networking CRDs, but OVN provider doesn't use these CRDs and so a cluster brought up with OVN plugin will not have them enabled. As a result the explain tests fail.


How reproducible: Always


Steps to Reproduce:
1. Bring up a cluster with ovn as the network provider.
2. Run oc explain tests in the conformance/parallel suite.
3. 

Actual results:

oc explain test fails 

Expected results:

No error is reported by the explain tests.

Additional info:

Comment 2 zhou ying 2020-02-03 03:58:50 UTC
Confirmed with latest oc client, can't reproduce the issue now:
[root@dhcp-140-138 ~]# ./oc version -o yaml 
clientVersion:
  buildDate: "2020-01-31T09:12:41Z"
  compiler: gc
  gitCommit: 709731817c7fef663038ab72dc13ea5fb0995cd2
  gitTreeState: dirty
  gitVersion: openshift-clients-4.4-17-g70973181
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.4.0-0.nightly-2020-02-02-201619

Comment 3 Aniket Bhat 2020-02-05 16:49:01 UTC
*** Bug 1796591 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-05-04 11:27:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.