RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1796238 - Texconfig requires the non-existent package tlmgr
Summary: Texconfig requires the non-existent package tlmgr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: texlive
Version: 8.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Than Ngo
QA Contact: Jakub Haruda
URL:
Whiteboard:
Depends On:
Blocks: 1819712
TreeView+ depends on / blocked
 
Reported: 2020-01-29 23:15 UTC by Ed Friedman
Modified: 2020-11-04 02:37 UTC (History)
2 users (show)

Fixed In Version: texlive-20180414-19.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 02:37:14 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4644 0 None None None 2020-11-04 02:37:19 UTC

Description Ed Friedman 2020-01-29 23:15:25 UTC
Description of problem:
texconfig fails because it depends on tlmgr and there seems to be no way to get tlmgr for RHEL 8

Version-Release number of selected component (if applicable):
texlive-texconfig-20180414-14.el8.noarch
texlive-tetex-20180414-14.el8.noarch

How reproducible:
Always

Steps to Reproduce:
1.Type:  texconfig-sys paper letter
2.Type:  texconfig paper letter
3.

Actual results:
/usr/bin/texconfig: line 799: tlmgr: command not found
/usr/bin/texconfig: line 1406: tlmgr: command not found
/usr/bin/texconfig: line 1266: tlmgr: command not found


Expected results:
texconfig should work without these error messages

Additional info:
Everything works fine in RHEL 7

Comment 1 Than Ngo 2020-01-30 13:10:43 UTC
i can reproduce the issue, tlmgr has been missing in texlive.infra.

Thanks for you report.

Comment 15 errata-xmlrpc 2020-11-04 02:37:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (texlive bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4644


Note You need to log in before you can comment on or make changes to this bug.