Bug 1796315 - [REF] Insights missing crash looping pods report
Summary: [REF] Insights missing crash looping pods report
Keywords:
Status: CLOSED DUPLICATE of bug 1860032
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Martin Kunc
QA Contact: Angelina Vasileva
Radek Vokál
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-30 07:06 UTC by Radek Vokál
Modified: 2020-09-14 12:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-14 12:46:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Radek Vokál 2020-01-30 07:06:35 UTC
Insights missing crash looping pods report (at least our pods in openshift- namespaces)

Michal Fojtik will provide more details if needed.

Comment 1 Michal Fojtik 2020-01-30 10:07:30 UTC
Insights operator should be able to list all pods in all openshift-* namespaces and detect crashlooping pods and send it via telemetry payload.
We can start with listing all pods (as YAML) and filtering those that are not running or have restart count == 0.

Comment 2 Alexandre Vicenzi 2020-02-07 12:44:35 UTC
AFAIK this is the default behavior. We can look over to send this type of data, but I would consider this as a feature request with low priority and not a bug.

Any other thoughts?

Comment 3 Radek Vokál 2020-03-05 13:25:00 UTC
It is a feature request, let's discuss the priority based on your estimate to implement this. Feel free to create a jira card, link it here and close this bug.

Comment 4 Alexandre Vicenzi 2020-03-05 14:53:23 UTC
I will leave this open until we plan what to do. As this is RFE we need first to evaluate the value of such data.

Comment 5 Martin Kunc 2020-06-01 05:03:57 UTC
This is not a blocked for 4.5, moving to 4.5.0


Note You need to log in before you can comment on or make changes to this bug.