Bug 1796418 - Sidebar resource for knative associated deployment shows blank resource
Summary: Sidebar resource for knative associated deployment shows blank resource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-30 11:56 UTC by Jaivardhan Kumar
Modified: 2020-05-13 21:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Due to rendering issue with component lifecycle in case of Sidebar resource for knative associated deployment shows blank resource on listView Consequence: Sidebar resource for knative associated deployment shows blank resource on listView Fix: handled component lifecycle to render the proper component in case of the sidebar is open and when the user clicks on a different item. Result: Resource tab on the sidebar in list view shows associated workloads in case of knative deployments show associated Revisions/Routes/Configurations and other deployment should show regular Pods/build/service/routes
Clone Of:
Environment:
Last Closed: 2020-05-13 21:55:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of resource tab (283.53 KB, image/jpeg)
2020-01-30 11:56 UTC, Jaivardhan Kumar
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4118 None closed Bug 1796418: fixes resource tab for sidebar for knative associated deployment 2020-04-20 11:26:56 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:55:42 UTC

Description Jaivardhan Kumar 2020-01-30 11:56:56 UTC
Created attachment 1656481 [details]
Screenshot of resource tab

Description of problem: 
Sidebar resource for knative associated deployment shows blank resource in list view


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. Install OpenShift Serverless operator
2. Create a knative service with DevConsole Add flow
3. Go topology and click on list view, click on knative Deployment

Actual results:
Sidebar for knative associated deployment shows blank resource in list view.

Expected results:
It should show associated routes/configurations and revisions.

Additional info:
NA

Comment 2 Gajanan More 2020-03-02 11:42:08 UTC
https://issues.redhat.com/browse/ODC-2866 verified by Gajanan More

Comment 4 errata-xmlrpc 2020-05-13 21:55:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.