Bug 1796421 - Serverless resources are listed as v1beta1, instead of v1
Summary: Serverless resources are listed as v1beta1, instead of v1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jaivardhan Kumar
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks: 1800615
TreeView+ depends on / blocked
 
Reported: 2020-01-30 12:05 UTC by Jaivardhan Kumar
Modified: 2020-05-13 21:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Serverless resources like Service yaml are listed as v1beta1, instead of v1(v1beta1 is deprecated) as in serverless operator 1.4 Consequence: v1beta1 is deprecated Fix: Update apiVersion to v1 Result: Version up to date with GA release for serverless operator
Clone Of:
: 1800615 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:55:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
Serverless resources are listed as v1beta1, instead of v1 when creating new service of Serverless (84.23 KB, image/png)
2020-02-10 11:04 UTC, spathak@redhat.com
no flags Details
Serverless resources are listed as v1beta1, instead of v1 when creating knative service through git import flow (147.14 KB, image/png)
2020-02-10 11:06 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4075 None closed Bug 1796421: Update serverless apiVersion from v1beta1 to v1 and updates URI acronym 2020-07-23 16:21:06 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:55:43 UTC

Description Jaivardhan Kumar 2020-01-30 12:05:19 UTC
Description of problem:
Serverless resources like Service yaml are listed as v1beta1, instead of v1(v1beta1 is deprecated).

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Install OpenShift Serverless operator
2. Go to Admin Console, click on Serverless -> Service -> Create Service 
3. Can see apiVersion as v1beta1

Actual results:
In Knative service yaml, apiVersion is v1beta1

Expected results:
In Knative service yaml, apiVersion should  be v1

Comment 2 spathak@redhat.com 2020-02-10 11:04:12 UTC
Created attachment 1662116 [details]
Serverless resources are listed as v1beta1, instead of v1 when creating new service of Serverless

Comment 3 spathak@redhat.com 2020-02-10 11:06:45 UTC
Created attachment 1662118 [details]
Serverless resources are listed as v1beta1, instead of v1 when creating knative service through git import flow

Comment 4 spathak@redhat.com 2020-02-10 11:32:33 UTC
Verified on build: 4.4.0-0.ci-2020-02-09-194845
Chrome browser: 76.0.3809.132

Comment 6 errata-xmlrpc 2020-05-13 21:55:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.