Bug 1796444 - gcp-routes-controller has to use /readyz instead of /healthz
Summary: gcp-routes-controller has to use /readyz instead of /healthz
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Antonio Murdaca
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks: 1796563
TreeView+ depends on / blocked
 
Reported: 2020-01-30 13:06 UTC by Antonio Murdaca
Modified: 2020-05-04 11:28 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1796563 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1417 None closed Bug 1796444: gcp: use readyz endpoint 2020-05-03 18:42:42 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:20 UTC

Description Antonio Murdaca 2020-01-30 13:06:27 UTC
Following the discussion here https://github.com/openshift/machine-config-operator/pull/1031#discussion_r371965677 we need to use the /readyz endpoint instead of the /healthz which we're currently using in gcp-routes-controller.

Not fully aware of how reproducible this is and/or how to verify it (maybe just looking at the CI and our own tests)

Comment 4 errata-xmlrpc 2020-05-04 11:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.