Bug 1796450 - Disable zoom-in feature for QueryBrowser component
Summary: Disable zoom-in feature for QueryBrowser component
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Vikram Raj
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-30 13:13 UTC by Vikram Raj
Modified: 2020-05-04 11:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
GIF to see the current behaviour (226.38 KB, image/gif)
2020-01-30 13:13 UTC, Vikram Raj
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4122 None closed Bug 1796450: Disable the zoom feature for QueryBrowser when hideControls props is true 2020-04-22 18:51:21 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:20 UTC

Description Vikram Raj 2020-01-30 13:13:36 UTC
Created attachment 1656496 [details]
GIF to see the current behaviour

Description of problem:

QueryBrowser component should disable the zoom-in feature if hideControls prop set to be true. But currently, it only hides the Reset Zoom button.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Navigate to the devconsole monitoring dashboard
2. Hover over the graph and notice the mouse pointer change to drag.
3. Click on the graph start dragging and it will zoom in the graph.

Actual results:
Users are able to zoom in the graph but there is no option to reset the zoom.

Expected results:
Users should not be able to zoom-in the graph on the monitoring dashboard.

Additional info:

Comment 2 Gajanan More 2020-03-02 11:11:40 UTC
https://issues.redhat.com/browse/ODC-2779 verified by Jai Kumar

Comment 4 errata-xmlrpc 2020-05-04 11:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.