Bug 1796465 - Selecting or Deleting an edge to/from a collapsed group fails
Summary: Selecting or Deleting an edge to/from a collapsed group fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-30 13:37 UTC by Jeff Phillips
Modified: 2020-05-04 11:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4081 None closed Bug 1796465: Fix for aggregate edge selection 2020-06-16 14:53:31 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:20 UTC

Description Jeff Phillips 2020-01-30 13:37:37 UTC
Description of problem:

For an edge to/from a collapsed group that represents just one edge, selected the edge fails (causing a blank screen. Removing the edge (via the trash can) brings up the confirmation modal, but the edge is not removed upon confirmation.

Version-Release number of selected component (if applicable):


How reproducible:

Every time

Steps to Reproduce:
1. Select an edge to/from a collapsed group that represents just one edge 

Actual results:

UI goes blank

Expected results:

display the side bar with the information on the single edge

Additional info:

Attempting to delete the same edge via the trash can also fails, The confirmation modal is displayed but the edge is not removed upon confirmation, no error shown.

Comment 1 Jeff Phillips 2020-01-30 13:39:11 UTC
PR https://github.com/openshift/console/pull/4081

Comment 3 Gajanan More 2020-03-02 11:10:59 UTC
https://issues.redhat.com/browse/ODC-2852 verified by Aritra Roy

Comment 5 errata-xmlrpc 2020-05-04 11:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.