Bug 1796479 - [OCP43][OSP][Installer] Cluster destroy causes floating IP address being deleted
Summary: [OCP43][OSP][Installer] Cluster destroy causes floating IP address being deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-30 14:28 UTC by Rafal Szmigiel
Modified: 2020-06-10 22:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3025 None closed Bug 1796479: OpenStack: dissociate api fips instead of deleting them 2020-06-10 22:34:30 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:20 UTC

Description Rafal Szmigiel 2020-01-30 14:28:24 UTC
Description of problem:
Destroying the cluster using:
$ ./openshift-install destroy cluster --dir config/

deletes FIP allocated for OCP's API. In my opinion IP should not be deleted but unassigned. In other case deleted IP address can be taken over by other OSP user what will require DNS reconfiguration if one is re-creating the cluster.

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1. Configure and create the cluster
2. Delete the cluster
3. Observe that Floating IP address configured for API doesn't exist anymore

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated
Cluster destroy causes API's FIP being deleted.

Expected results:
Floating IP address previously assigned for OCP API should be unassigned and still bounded to the project where it was originally created.


Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Martin André 2020-01-30 15:17:36 UTC
Could you paste the command you used to create the API floating IP originally? It will help us understanding why your FIP was destroyed.

Comment 2 Rafal Szmigiel 2020-01-30 15:23:58 UTC
The API's FIP has been created outside of the installer using OpenStack's CLI:

$ openstack floating ip create --floating-ip-address 192.168.202.52 --project ocp4 public

then it was configured as the following:

(...)
platform:
  openstack:
    cloud: openstack
    computeFlavor: rht.ocp4node
    externalDNS: null
    externalNetwork: public
    lbFloatingIP: 192.168.202.52
(...)

Once I destroyed the cluster (after failed installation) I've noticed that 192.168.202.52 is gone. As it is "external" resource to the installer IMO it shouldn't be deleted.

Comment 3 Mike Fedosin 2020-01-30 15:54:59 UTC
Fix is on review: https://github.com/openshift/installer/pull/3025

Comment 5 David Sanz 2020-01-31 16:47:04 UTC
Verified on 4.4.0-0.nightly-2020-01-31-144949

Cluster deletion is not deleting the floating ip

Comment 7 errata-xmlrpc 2020-05-04 11:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.