Bug 1796521 - Notification Alert to set up monitoring should direct to cluster monitor config [openshift-4.4]
Summary: Notification Alert to set up monitoring should direct to cluster monitor conf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-30 16:01 UTC by Joe Caiani
Modified: 2020-05-13 21:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:55:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
ALAlertmanagerReceiversNotConfigured with Configure Receivers link (168.26 KB, image/png)
2020-02-12 09:14 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4257 0 None closed Bug 1796521: Notification drawer alert to setup monitoring directs user to config page 2020-05-13 22:00:30 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:55:48 UTC

Description Joe Caiani 2020-01-30 16:01:03 UTC
Description of problem: If monitoring is not set up an alert will be provided suggesting the cluster admin set up cluster alerts. The drawer should route the user to alert config for the cluster when that alert hits the drawer.


Version-Release number of selected component (if applicable):4.4


How reproducible: reproducible when the above alert is available and firing.

Comment 2 Yadan Pei 2020-02-12 09:06:17 UTC
fixes didn't land in 4.4.0-0.nightly-2020-02-11-203858, will check on newer build

Comment 3 Yadan Pei 2020-02-12 09:14:51 UTC
Created attachment 1662620 [details]
ALAlertmanagerReceiversNotConfigured with Configure Receivers link

Sorry, the fix was already merged in 4.4.0-0.nightly-2020-02-11-203858


1. Open Notification Drawer
2. in Other Alerts, we can see ALAlertmanagerReceiversNotConfigured alert along with 'Configure Receivers' link, click on 'Configure Receivers' will direct user to /monitoring/alertmanagerconfig page

Comment 5 errata-xmlrpc 2020-05-13 21:55:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.