Bug 1796627 - debugging issues with the bootstap host is hard because it's automatically removed
Summary: debugging issues with the bootstap host is hard because it's automatically re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Stephen Benjamin
QA Contact: Yang Yang
URL:
Whiteboard:
: 1809509 (view as bug list)
Depends On:
Blocks: 1798060
TreeView+ depends on / blocked
 
Reported: 2020-01-30 19:31 UTC by Scott Dodson
Modified: 2020-05-04 11:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
This is a developer oriented change and should NOT make it into product documentation.
Clone Of:
: 1798060 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:28:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 2935 0 None closed Bug 1796627: cmd/openshift-install/create: add env var to preserve bootstrap 2021-01-27 08:13:01 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:28:48 UTC

Description Scott Dodson 2020-01-30 19:31:38 UTC
debugging issues with the bootstap host is hard because it's automatically removed, we should provide an option to leave it around

Comment 2 Yang Yang 2020-02-03 11:26:22 UTC
Verified with openshift-install 4.4.0-0.nightly-2020-02-03-005212

Steps of verification as below:
1. Set environment variable
export OPENSHIFT_INSTALL_PRESERVE_BOOTSTRAP=true

2. Install an IPI cluster
[root@preserve-yangyangmerrn-1 build]# openshift-install create cluster --dir=bz
? SSH Public Key /root/.ssh/id_rsa.pub
? Platform gcp
INFO Credentials loaded from file "/root/.gcp/osServiceAccount.json" 
? Project ID openshift-qe
? Region us-central1
? Base Domain qe.gcp.devcluster.openshift.com
? Cluster Name yang
? Pull Secret [? for help] 
INFO Creating infrastructure resources...         
INFO Waiting up to 20m0s for the Kubernetes API at https://api.yang.qe.gcp.devcluster.openshift.com:6443... 
INFO API v1.17.1 up                               
INFO Waiting up to 40m0s for bootstrapping to complete... 
WARNING OPENSHIFT_INSTALL_PRESERVE_BOOTSTRAP is set, not destroying bootstrap resources. Warning: this should only be used for debugging purposes, and poses a risk to cluster stability. 
INFO Waiting up to 30m0s for the cluster at https://api.yang.qe.gcp.devcluster.openshift.com:6443 to initialize... 
INFO Waiting up to 10m0s for the openshift-console route to be created... 
INFO Install complete!                            
INFO To access the cluster as the system:admin user when using 'oc', run 'export KUBECONFIG=/root/build/bz/auth/kubeconfig' 
INFO Access the OpenShift web-console here: https://console-openshift-console.apps.yang.qe.gcp.devcluster.openshift.com 
INFO Login to the console with user: kubeadmin, password: 2zT3p-mNJnJ-Z3UiL-ezPaA 

Bootstrap is kept after installation completes.

3. Destroy the cluster
After cluster destoying, bootstrap is destroyed

The test results are as expected hence moving it to verified state

Comment 3 Stephen Benjamin 2020-03-03 14:31:10 UTC
*** Bug 1809509 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-05-04 11:28:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.