Bug 1796634 - specDescriptor urn:alm:descriptor:com.tectonic.ui:booleanSwitch does not default to false [openshift-4.2]
Summary: specDescriptor urn:alm:descriptor:com.tectonic.ui:booleanSwitch does not defa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1797086
Blocks: 1797091
TreeView+ depends on / blocked
 
Reported: 2020-01-30 19:50 UTC by Matt Dorn
Modified: 2020-03-04 04:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1797086 1797091 (view as bug list)
Environment:
Last Closed: 2020-03-04 04:51:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4142 None closed [release-4.2] Bug 1796634: Fix bug where booleanSwitch does not default to false 2020-03-02 21:23:36 UTC
Red Hat Product Errata RHBA-2020:0614 None None None 2020-03-04 04:51:12 UTC

Description Matt Dorn 2020-01-30 19:50:07 UTC
Description of problem:
In OpenShift 4.2, use of urn:alm:descriptor:com.tectonic.ui:booleanSwitch does not default to false as detailed here:

https://github.com/openshift/console/blob/master/frontend/packages/operator-lifecycle-manager/src/components/descriptors/reference/reference.md#4-booleanswitch

It will default to true.

Using specDescriptors.value = [false] will also show true.

Using specDescriptors.value = "false" in 4.2 will show false, but this is a mis-use of this field as it should only accept type byte rawJson. This will be enforced in OCP 4.4

See https://bugzilla.redhat.com/show_bug.cgi?id=1794580 for more information.

Version-Release number of selected component (if applicable):
4.2

How reproducible:

Install CSV with booleanSwitch, example:

      specDescriptors:
      - description: A description of this switch
        displayName: Paused
        path: paused
        x-descriptors:
        - urn:alm:descriptor:com.tectonic.ui:booleanSwitch

Expected result:

Should default to false as specified in docs

Additional Information:
This issue does not occur on 4.3 and 4.4.

Comment 3 Yanping Zhang 2020-02-24 07:44:11 UTC
Tested on ocp 4.2 env with payload: 4.2.0-0.nightly-2020-02-23-045604.
Install etcd operator in project, then in crd add description for etcd cluster with example below, then create etcd cluster cvs. Check on the csv detail page, the "Paused" boolean value is "false" by default.
      - description: A description of this switch
        displayName: Paused
        path: paused
        x-descriptors:
        - urn:alm:descriptor:com.tectonic.ui:booleanSwitch

The bug is fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2020-03-04 04:51:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0614


Note You need to log in before you can comment on or make changes to this bug.