Bug 1796660 - [4.4] duplicate delete commands are seen when deleting PVs backed by vsphere volumes; first call succeeds, second fails with disk not found [NEEDINFO]
Summary: [4.4] duplicate delete commands are seen when deleting PVs backed by vsphere ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.11.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Hemant Kumar
QA Contact: Wei Duan
URL:
Whiteboard:
Depends On: 1809781
Blocks: 1808548 1808551
TreeView+ depends on / blocked
 
Reported: 2020-01-30 21:28 UTC by milti leonard
Modified: 2020-05-04 11:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1808548 1808549 1808550 1808551 1809781 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:28:24 UTC
Target Upstream Version:
hekumar: needinfo? (mleonard)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24625 0 None closed [4.4] Bug 1796660: UPSTREAM: 88146: remove duplicate pv delete calls 2020-11-06 02:18:46 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:28:48 UTC

Description milti leonard 2020-01-30 21:28:11 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0
Build Identifier: 

when deleting a PV that is backed by a vsphere volume (VMDK), the delete command is duplicated; initial delete call will succeed on volume; however the second delete call on the same volume will fail w *vmdk not found* as it has already been deleted and confirmed as deleted in logs. 

customer configuration seems good and this is happening in more than one cluster; each cluster has only one datastore defined.

Reproducible: Didn't try

Steps to Reproduce:
1. configure vsphere datastore for cluster
2. create PV/PVC 
3. delete PVC and then PV


Expected Results:  
after VMDK has been confirmed as deleted; there is no duplicate delete call on the deleted VMDK

the customer has not reported business impact, but their vmware console is flooded with the errors from the failed duplicated delete command; this is not restricted to a single cluster/namespace/node/datastore, but happens everywhere in their environment

customer is using several different storageclasses, but this issue only appears on the storageclass backed by vsphere

Comment 9 errata-xmlrpc 2020-05-04 11:28:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.