Bug 179680 - System hangs after kudzu configures AIC-29320ALP SCSI Controller
System hangs after kudzu configures AIC-29320ALP SCSI Controller
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 19:11 EST by Chuck Buda
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 17:22:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Buda 2006-02-01 19:11:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
We received an IBM x260 server with a Adapter AIC-29320ALP SCSI Controller.  There are no RHv4 device drivers for this device.  Kudzu and the OS do not see this device.  However, after updating the system, kudzu suddenly "finds" the device and asks if I want to configure it.  When I do, the system hangs.  The last message seen is "Starting HAL Daemon     [OK]".  The system can be rebooted to Single User mode but removal of the device from the hwconf file does not fix the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Load RH Enterprise AS v4 on system.
2.  Run update2.
3.  Reboot system.
4.  Let kudzu configure the device.
5.  Watch system hang.

Actual Results:  See Description.

Expected Results:  System should have booted to multi-user level.

Additional info:
Comment 1 Bill Nottingham 2006-02-01 23:01:39 EST
If you enable sysrq (kernel.sysrq=1 in /etc/sysctl.conf), and, when it hangs,
hit 'alt-sysrq-t', what does it print? (alt-sysrq-p may also be useful.)
Comment 2 Chuck Buda 2006-02-02 11:18:25 EST
Made the change to /etc/sysctl/.conf and rebooted the system.  It hung again and
I hit the 'alt-sysrq-t' and 'alt-sysrq-p" ket sequences with no results.  The
server did nothing.
Comment 3 Chuck Buda 2006-02-03 13:27:05 EST
I've removed the SCSI controller, reloaded the OS, ran update2 to bring it to
most current level.  System ran for over 15 hours before problems began.  I
tried to load an rpm package from a floppy disk.  System did not automount the
floppy disk.  Tried a manual mount which did not work.  Rebooted system and
original problem returned -- bootup display shows that the HAL daemon is being
started up [OK], then system froze.
Tried hard reboot.  System ran through BIOS startup fine.  It now froze after
saying that it had uncompressed Linux.  
Now what?
Comment 4 Chuck Buda 2006-02-03 17:22:50 EST
The problem was found to be a hardware problem.  Sorry for the trouble.

Note You need to log in before you can comment on or make changes to this bug.