Bug 179681 - Hangs with greater than 4GB memory installed
Hangs with greater than 4GB memory installed
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: memtest86+ (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 19:17 EST by Erich Boleyn
Modified: 2008-03-10 20:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 20:07:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erich Boleyn 2006-02-01 19:17:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3) Gecko/20040921

Description of problem:

I have a machine with greater than 4GB of memory installed, and the memtest86+ version included with Fedora Core 5 test 2 hangs hard on the first (and simplest) test when it gets to the 4-6 GB zone.  It never even counts up more than 0 seconds in it's time display.

NOTE: I have not verified that memtest86+ does this on multiple possible machines with this amount of memory installed.  I did verify that if I installed less than 4GB on this machine, it didn't hang, for what it's worth.

My machine is a Tyan S2882-D with Dual Opteron 275, 8 GB of memory total, 4GB of memory per node.

I have seen similar problems in the past in point releases of memtest86/memtest86+.

I grabbed the most recent released version of memtest86, version 3.2, and it does not appear to have this problem.  There may also be a more recent version of memtest86+ that may solve the problem, but I have not tried that.


Version-Release number of selected component (if applicable):
memtest86+-1.65

How reproducible:
Always

Steps to Reproduce:
1. Either get a machine with > 4GB of RAM, or one of the specific config I have listed in the Description field (haven't isolated that specifically).
2. Boot into the memory tester program distributed with Fedora Core 5 test 2.
3. Observe it immediately hangs after starting the test.  The time does not increment and it is unrespensive.


Actual Results:  Hang.


Expected Results:  Not hang.  It should go through the tests and the time should increment normally.


Additional info:

I set the severity as normal, even though it crashes, it's an optional test only run by some people.
Comment 1 Rahul Sundaram 2006-02-20 05:45:32 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Red Hat Bugzilla 2007-02-05 13:58:37 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 3 Samuel D. 2007-02-05 15:58:43 EST
I use an i975X motherboard with 8 GB of RAM and I tryed Memtest86+ on an 4-way
Opteron server with 4 GB per node (16 GB total) and it worked as expected.

BTW, I fixed many bugs in K8 initialization code on Memtest86+ 1.70, especially
for multi-node K8 systems. Could you try with this revision ?
Comment 4 Matthew Miller 2007-04-06 12:14:38 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 petrosyan 2008-03-10 20:07:49 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.