Bug 1796902 - Right click on topology graph area when no workloads results in blank screen
Summary: Right click on topology graph area when no workloads results in blank screen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-31 13:18 UTC by Jeff Phillips
Modified: 2020-05-04 11:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:28:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4141 None closed Bug 1796902: Fix for right click on graph when no workloads 2020-04-28 20:21:20 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:28:51 UTC

Description Jeff Phillips 2020-01-31 13:18:54 UTC
Description of problem:

When the topology view is shown with only knative services a right click on the graph causes the UI to go blank

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a new project
2. Add a serverless workload
3. From Topology, right click on the blank graph area

Actual results:

UI goes blank

Expected results:

A menu should appear allowing you to add items

Additional info:

Comment 2 Gajanan More 2020-03-02 11:25:53 UTC
https://issues.redhat.com/browse/ODC-2790 verified by Aritra Roy

Comment 4 errata-xmlrpc 2020-05-04 11:28:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.