Bug 1796927 - Comments describing telemetry is missing [NEEDINFO]
Summary: Comments describing telemetry is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-31 14:17 UTC by Frederic Branczyk
Modified: 2020-05-04 11:28 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:28:32 UTC
Target Upstream Version:
lcosic: needinfo? (fbranczy)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 640 0 None closed BUG 1796927: Documentation: Transfer telemetry comments 2020-03-10 10:03:36 UTC
Github openshift telemeter pull 306 0 None closed BUG 1796927: *: Move metrics whitelist to downstream usage 2020-03-10 10:03:41 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:28:51 UTC

Description Frederic Branczyk 2020-01-31 14:17:53 UTC
Description of problem:

In 4.4 a new mechanism to configure telemetry was introduced, this silently dropped the comments that described what each metric represents. These descriptions should be available for transparency.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Junqi Zhao 2020-02-04 02:03:15 UTC
tested with 4.4.0-0.nightly-2020-02-03-163409, just some defects in the comments.
the following 3 metrics are not the same with that in the comments
    # job:ceph_pools_iops:total is the total iops (reads+writes) value in bytes for all the pools in ceph cluster
    - '{__name__="job:ceph_pools_iops_bytes:total"}'

    # cluster:network_attachment_definition_enabled_instance_up  informs (1 or 0) if the cluster has
    # at least max of one instance with  k8s.v1.cni.cncf.io/networks annotation, labelled by networks (any or sriov).
    - '{__name__="cluster:network_attachment_definition_enabled_instance_up:max"}'

    # insightsclient_request_send tracks the number of metrics sends.
    - '{__name__="insightsclient_request_send_total"}'

Comment 4 Lili Cosic 2020-02-04 09:26:08 UTC
This sounds like the problem with the metrics as we did not touch any of the recording rules, think we should verify to confirm this before these changes landed.

Comment 5 Frederic Branczyk 2020-02-04 09:36:39 UTC
I double checked and while not totally correct as you identified, those are the comments those entries had previously, see: https://github.com/openshift/telemeter/blob/de3c19e9675f55b22e53104094926c584c5a8a60/docs/data-collection.md

As this bug was about transferring the comments, I would call this verified, and we can open a bug against each component that is responsible for these metrics, to have them fix the comments.

Comment 8 errata-xmlrpc 2020-05-04 11:28:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.