Bug 179695 - firefox segfaulted
firefox segfaulted
Status: CLOSED DUPLICATE of bug 179694
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 23:42 EST by Dave Jones
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 11:04:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-02-01 23:42:13 EST
I found a coredump in my ~ from a few days ago.

Core was generated by `/usr/lib64/firefox-1.5/firefox-bin -UILocale en-US'.
Program terminated with signal 11, Segmentation fault.

(gdb) bt
#0  0x0000003c3dd0cab9 in raise () from /lib64/libpthread.so.0
#1  0x000000000041350b in nsProfileLock::FatalSignalHandler (signo=11) at
nsProfileLock.cpp:206
#2  <signal handler called>
#3  0x000000367c30ff6e in FcGlobalCacheReadDir (set=0xb81360, dirs=Variable
"dirs" is not available.
) at fccache.c:310
#4  0x000000367c317179 in FcDirScanConfig (set=0xb81360, dirs=0xb79830,
cache=0xb7d710, blanks=0xb7b2a0,
    dir=0xb81430 "/home/davej/.fonts/fonts", force=0, config=0xb79780) at
fcdir.c:142
#5  0x000000367c3128b7 in FcConfigBuildFonts (config=0xb79780) at fccfg.c:304
#6  0x000000367c31a54d in FcInitLoadConfigAndFonts () at fcinit.c:85
#7  0x000000367c31a5e2 in FcInit () at fcinit.c:103
#8  0x000000367c311f63 in FcConfigGetCurrent () at fccfg.c:360
#9  0x000000367c313e30 in FcConfigSubstituteWithPat (config=0x0, p=0xb69390,
p_pat=0x0, kind=FcMatchPattern)
    at fccfg.c:1303
#10 0x000000367c706413 in pango_cairo_fc_font_map_get_type () from
/usr/lib64/libpangocairo-1.0.so.0
#11 0x000000367c9095c8 in pango_fc_font_map_get_type () from
/usr/lib64/libpangoft2-1.0.so.0
#12 0x000000367cb1432d in pango_context_get_font_description () from
/usr/lib64/libpango-1.0.so.0
#13 0x000000367cb145fc in pango_itemize_with_base_dir () from
/usr/lib64/libpango-1.0.so.0
#14 0x000000367cb146d9 in pango_itemize () from /usr/lib64/libpango-1.0.so.0
#15 0x00002aaaabe32d13 in nsFontMetricsPango::CacheFontMetrics (this=0xb6b800)
at nsFontMetricsPango.cpp:265
#16 0x00002aaaabe34b9d in nsFontMetricsPango::Init (this=0xb6b800,
aFont=Variable "aFont" is not available.
) at nsFontMetricsPango.cpp:251
#17 0x00002aaaab058a2b in nsFontCache::GetMetricsFor (this=0xb6b760,
aFont=@0xb66ec8, aLangGroup=0x972830,
    aMetrics=@0x7ffffff99330) at nsDeviceContext.cpp:631
#18 0x00002aaaac82eae0 in nsHTMLReflowState::CalcLineHeight
(aPresContext=Variable "aPresContext" is not available.
) at nsHTMLReflowState.cpp:2263
#19 0x00002aaaac8163bb in nsBlockReflowState (this=0x7ffffff99490,
aReflowState=@0x7ffffff997e0,
    aPresContext=0xb2c7d0, aFrame=0xb66a00, aMetrics=@0x7ffffff998f0,
aTopMarginRoot=4194304,
    aBottomMarginRoot=4194304) at nsBlockReflowState.cpp:172
#20 0x00002aaaac813632 in nsBlockFrame::Reflow (this=0xb66a00,
aPresContext=0xb2c7d0, aMetrics=@0x7ffffff998f0,
    aReflowState=@0x7ffffff997e0, aStatus=@0x7ffffff99b5c) at nsBlockFrame.cpp:770
#21 0x00002aaaac81a0a0 in nsContainerFrame::ReflowChild (this=Variable "this" is
not available.
) at nsContainerFrame.cpp:904
#22 0x00002aaaac82ddd3 in CanvasFrame::Reflow (this=0xb33590,
aPresContext=0xb2c7d0, aDesiredSize=@0x7ffffff99c00,
    aReflowState=@0x7ffffff99a10, aStatus=@0x7ffffff99b5c) at nsHTMLFrame.cpp:531
#23 0x00002aaaac81a0a0 in nsContainerFrame::ReflowChild (this=Variable "this" is
not available.
) at nsContainerFrame.cpp:904
#24 0x00002aaaac82abdb in nsHTMLScrollFrame::ReflowScrolledFrame (this=0xb337d8,
aState=@0x7ffffff99ce0,
    aAssumeHScroll=Variable "aAssumeHScroll" is not available.
) at nsGfxScrollFrame.cpp:515
#25 0x00002aaaac82acea in nsHTMLScrollFrame::ReflowContents (this=0xb337d8,
aState=0x7ffffff99ce0,
    aDesiredSize=@0x7ffffff9a120) at nsGfxScrollFrame.cpp:570
#26 0x00002aaaac82b97d in nsHTMLScrollFrame::Reflow (this=0xb337d8,
aPresContext=Variable "aPresContext" is not available.
) at nsGfxScrollFrame.cpp:768
#27 0x00002aaaac81a0a0 in nsContainerFrame::ReflowChild (this=Variable "this" is
not available.
) at nsContainerFrame.cpp:904
#28 0x00002aaaac861c79 in ViewportFrame::Reflow (this=0xb33490,
aPresContext=0xb2c7d0, aDesiredSize=@0x7ffffff9a300,
    aReflowState=@0x7ffffff9a1f0, aStatus=@0x7ffffff9a3ac) at
nsViewportFrame.cpp:239
#29 0x00002aaaac7fc8d5 in PresShell::InitialReflow (this=0xb321f0,
aWidth=Variable "aWidth" is not available.
) at nsPresShell.cpp:2858
#30 0x00002aaaac927bbc in nsContentSink::StartLayout (this=0xb28630,
aIsFrameset=Variable "aIsFrameset" is not available.
) at nsContentSink.cpp:921
#31 0x00002aaaac9c9944 in HTMLContentSink::OpenBody (this=0xb28630,
aNode=@0xb356e0) at nsHTMLContentSink.cpp:2633
#32 0x00002aaaad5e8985 in CNavDTD::OpenBody (this=0xb352b0, aNode=0xb356e0) at
CNavDTD.cpp:2968
#33 0x00002aaaad5eb26e in CNavDTD::HandleDefaultStartToken (this=0xb352b0,
aToken=0xb26d60, aChildTag=eHTMLTag_body,
    aNode=0xb356e0) at CNavDTD.cpp:1281
#34 0x00002aaaad5ebc1f in CNavDTD::HandleStartToken (this=0xb352b0,
aToken=0xb26d60) at CNavDTD.cpp:1668
#35 0x00002aaaad5ec02a in CNavDTD::HandleToken (this=0xb352b0, aToken=0xb26d60,
aParser=0xb26a00) at CNavDTD.cpp:955
#36 0x00002aaaad5ec461 in CNavDTD::BuildModel (this=0xb352b0, aParser=0xb26a00,
aTokenizer=Variable "aTokenizer" is not available.
) at CNavDTD.cpp:458
#37 0x00002aaaad5f6f01 in nsParser::BuildModel (this=0xb26a00) at nsParser.cpp:2127
#38 0x00002aaaad5f9ee0 in nsParser::ResumeParse (this=0xb26a00,
allowIteration=1, aIsFinalChunk=0, aCanInterrupt=1)
    at nsParser.cpp:1994
#39 0x00002aaaad5f66ee in nsParser::OnDataAvailable (this=0xb26a00,
request=Variable "request" is not available.
) at nsParser.cpp:2674
#40 0x00002acb0fc2c523 in nsInputStreamPump::OnStateTransfer (this=0x7c0f80) at
nsInputStreamPump.cpp:437
#41 0x00002acb0fc2c607 in nsInputStreamPump::OnInputStreamReady (this=0x7c0f80,
stream=Variable "stream" is not available.
) at nsInputStreamPump.cpp:340
#42 0x00002acb0bf67f11 in nsInputStreamReadyEvent::EventHandler
(plevent=Variable "plevent" is not available.
) at nsStreamUtils.cpp:119
#43 0x00002acb0bf7899f in PL_HandleEvent (self=0x7c1008) at plevent.c:688
#44 0x00002acb0bf78bb1 in PL_ProcessPendingEvents (self=0x5d87d0) at plevent.c:623
#45 0x00002acb0bf79f7b in nsEventQueueImpl::ProcessPendingEvents (this=0x59e500)
at nsEventQueue.cpp:417
#46 0x00002aaaaaf1b942 in event_processor_callback (source=Variable "source" is
not available.
) at nsAppShell.cpp:67
#47 0x0000003cdc224e91 in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#48 0x0000003cdc227cad in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#49 0x0000003cdc227ffe in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#50 0x000000367ce0bf55 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#51 0x00002aaaaaf1bc72 in nsAppShell::Run (this=0x6c1c90) at nsAppShell.cpp:139
#52 0x00002aaaab391464 in nsAppStartup::Run (this=0x6c1c10) at nsAppStartup.cpp:150
#53 0x000000000040b20b in XRE_main (argc=Variable "argc" is not available.
) at nsAppRunner.cpp:2313
#54 0x0000003c3b91cde4 in __libc_start_main () from /lib64/libc.so.6
#55 0x0000000000406b29 in _start ()
#56 0x00007ffffff9b3b8 in ?? ()
#57 0x0000000000000000 in ?? ()
Comment 1 Matthias Clasen 2006-02-06 11:04:34 EST

*** This bug has been marked as a duplicate of 179694 ***

Note You need to log in before you can comment on or make changes to this bug.