Bug 179712 - enable r300 driver with dri default off
enable r300 driver with dri default off
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: FutureFeature
Depends On:
Blocks: FC6Target FC5Update
  Show dependency treegraph
 
Reported: 2006-02-02 05:48 EST by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 18:02:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2006-02-02 05:48:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Epiphany/1.9.6

Description of problem:
As requested on IRC

<mharris> File a bug report against xorg-x11-drv-ati to request the r300 driver be enabled, but dri disabled by default if you'd like to keep me reminded ;)
<mharris> Then sometime I'll whip up the "disable by default" patch for the radeon driver, and enable the 3D driver in mesa
<mharris> Assuming nobody vetoes the idea between now and FC5 of course ;)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.


Additional info:
Comment 1 Mike A. Harris 2006-02-07 06:36:43 EST
I've enabled the experimental r300 driver in Mesa 6.4.2-2 for the time being
at least, to see how it goes.  I have not disabled DRI by default in the
"radeon" driver for R300 hardware yet however, but if we keep the r300
DRI driver enabled for FC5, we'll probably disable it by default at runtime,
and users who want to test it out will then have to use Option "dri" in the
device section of the config file to enable DRI for the chips.

Please note though, that this is being enabled strictly as a convenience
to users who want to experiment with the unsupported r300 DRI driver without
having to recompile mesa themselves.  When DRI is enabled and this driver is
being used, any bugs that occur with X at all, should be directly reported
to X.Org bugzilla so that the r300 driver developers are directly aware of
the problem.  Red Hat bugzilla should not be used for reporting problems
while using R300 DRI support.

As an additional note to all users, this is just a test to see how well
the driver works in practice.  We may decide to disable the driver in future
builds if it turns out to be very unstable, or if it causes too many bugs
reported in Red Hat bugzilla instead of X.Org bugzilla.

mesa-6.4.2-2 is now built internally, and should end up in rawhide in about
24 hours.

Leaving bug open so the 'radeon' driver changes can be made.
Comment 3 John Thacker 2006-02-26 13:59:51 EST
FWIW, there are some important mmap fixes that hit xorg CVS on February 17th. 
Without them, there are apparently a decent number of lockups and hangs with
R300 cards (and possibly other R300 cards), even without DRI support enabled. 
See his post here:
http://lists.freedesktop.org/archives/xorg/2005-December/011678.html

They hit CVS on the 17th, and aren't in 7.0.  If necessary to prevent crashes,
they might should be considered as patches for the Fedora tree.
Comment 4 Mike A. Harris 2006-02-28 15:30:07 EST
(In reply to comment #3)
> FWIW, there are some important mmap fixes that hit xorg CVS on February 17th. 
> Without them, there are apparently a decent number of lockups and hangs with
> R300 cards (and possibly other R300 cards), even without DRI support enabled. 
> See his post here:
> http://lists.freedesktop.org/archives/xorg/2005-December/011678.html
> 
> They hit CVS on the 17th, and aren't in 7.0.  If necessary to prevent crashes,
> they might should be considered as patches for the Fedora tree.

"It's not 7.0 material but I expect to commit the patch (or a successor) to
 CVS right after that, and it might hit a subsequence stable release as a bug
 fix."

The patch has not been commited to the stable branch thus far, which
indicates that it is not yet considered stable enough for the stable
branch.

Having said that, we are aware the patch exists, however it has not yet had
adequate in the wild testing, so including it in FC5 this close to the final
release could potentially cause more harm than good.

Please patch the driver src.rpm with this patch and update the report with
the result of your testing.
Comment 5 Mike A. Harris 2006-03-01 02:16:37 EST
Deferring r300 dri driver consideration for FC6, and possibly FC5update
Comment 6 Mike A. Harris 2006-05-18 18:02:23 EDT
The R300 DRI driver is present now in mesa-libGL in rawhide.

Note You need to log in before you can comment on or make changes to this bug.