Bug 1797122 - kubeapiserver rollout with storage config takes more time on update during bootstrap
Summary: kubeapiserver rollout with storage config takes more time on update during bo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-31 23:43 UTC by Alay Patel
Modified: 2020-05-13 21:58 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:58:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 68 0 None closed Bug 1797122: add hack for KAS rollouts, make cmc chattier 2020-10-13 17:44:05 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:58:33 UTC

Description Alay Patel 2020-01-31 23:43:46 UTC
Description of problem:

kube-apiserver rolls out new pod every time storage config changes. storage config depends on host-etcd. To avoid this start host-etcd will all four etcd (bootstrap and all 3 masters). This will make sure that the very first rollout of kubeapiserver is configured with more urls and reduce bootstrap time because of cluster-etcd-operator. 

The clustermembercontroller needs more chatter, add other resource informers

Comment 2 ge liu 2020-03-09 07:51:42 UTC
No regression issue found.

Comment 4 errata-xmlrpc 2020-05-13 21:58:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.