Bug 1797223 - xfreerdp error when using /video
Summary: xfreerdp error when using /video
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freerdp
Version: 31
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Simone Caronni
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-01 15:31 UTC by Stefan Assmann
Modified: 2021-01-14 10:40 UTC (History)
5 users (show)

Fixed In Version: freerdp-2.0.0-56.20200207git245fc60.fc31 freerdp-2.0.0-56.20200207git245fc60.fc30 freerdp-2.1.2-1.fc32 freerdp-2.1.2-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-09 01:04:58 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github FreeRDP FreeRDP issues 6236 0 None closed Loading of video channel fails with "undefined symbol: mappedGeometryRef" 2021-01-14 10:40:11 UTC

Description Stefan Assmann 2020-02-01 15:31:18 UTC
Description of problem:
The following error occurs
xfreerdp /cert-ignore /u:User /gfx /v:192.168.0.13 /video
[16:26:47:876] [25304:25305] [INFO][com.freerdp.client.common.cmdline] - loading channelEx rdpdr
[16:26:47:876] [25304:25305] [INFO][com.freerdp.client.common.cmdline] - loading channelEx rdpsnd
[16:26:47:876] [25304:25305] [INFO][com.freerdp.client.common.cmdline] - loading channelEx cliprdr
[16:26:47:876] [25304:25305] [INFO][com.freerdp.client.common.cmdline] - loading channelEx drdynvc
Password:
[16:26:50:645] [25304:25305] [INFO][com.freerdp.gdi] - Local framebuffer format  PIXEL_FORMAT_BGRX32
[16:26:50:645] [25304:25305] [INFO][com.freerdp.gdi] - Remote framebuffer format PIXEL_FORMAT_BGRA32
[16:26:50:656] [25304:25305] [INFO][com.winpr.clipboard] - initialized POSIX local file subsystem
[16:26:50:673] [25304:25305] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel rdpgfx
[16:26:50:673] [25304:25323] [INFO][com.freerdp.channels.rdpsnd.client] - Loaded fake backend for rdpsnd
[16:26:50:673] [25304:25305] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel geometry
[16:26:50:673] [25304:25305] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel video
[16:26:50:673] [25304:25305] [ERROR][com.winpr.library] - LoadLibraryA failed with /usr/lib64/freerdp2/libvideo-client.so: undefined symbol: mappedGeometryRef
[16:26:50:673] [25304:25305] [WARN][com.freerdp.addin] - Failed to load channel video [(nil)]
[16:26:50:673] [25304:25305] [ERROR][com.freerdp.channels.drdynvc.client] - drdynvc_virtual_channel_event_connected failed with error 1
[16:26:50:677] [25304:25305] [ERROR][com.freerdp.core] - drdynvc_virtual_channel_init_event_ex reported an error. Error was 1
[16:26:50:677] [25304:25305] [ERROR][com.freerdp.core] - checkChannelErrorEvent() failed - 0


Works if /video is removed.

Version-Release number of selected component (if applicable):
freerdp-2.0.0-53.20190820git6015229.fc31.x86_64
freerdp-libs-2.0.0-53.20190820git6015229.fc31.x86_64

How reproducible:
always

Steps to Reproduce:
1. xfreerdp /cert-ignore /u:User /gfx /v:192.168.0.13 /video
2.
3.

Comment 1 Fedora Update System 2020-02-08 16:53:48 UTC
FEDORA-2020-2404c9ff3b has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-2404c9ff3b

Comment 2 Fedora Update System 2020-02-09 01:21:04 UTC
freerdp-2.0.0-56.20200207git245fc60.fc31, guacamole-server-1.1.0-5.fc31, remmina-1.3.10-1.fc31, vinagre-3.22.0-17.fc31, weston-7.0.0-3.fc31, wlroots-0.6.0-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-483cbdf643

Comment 3 Fedora Update System 2020-02-09 01:46:51 UTC
freerdp-2.0.0-56.20200207git245fc60.fc30, guacamole-server-1.1.0-5.fc30, remmina-1.3.10-1.fc30, vinagre-3.22.0-16.fc30, weston-6.0.1-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-2404c9ff3b

Comment 4 Stefan Assmann 2020-02-10 09:22:24 UTC
Sill getting the error
[16:26:50:673] [25304:25305] [ERROR][com.winpr.library] - LoadLibraryA failed with /usr/lib64/freerdp2/libvideo-client.so: undefined symbol: mappedGeometryRef
with
$ rpm -qf /usr/lib64/freerdp2/libvideo-client.so
freerdp-libs-2.0.0-56.20200207git245fc60.fc31.x86_64

Comment 5 Fedora Update System 2020-02-11 01:13:56 UTC
freerdp-2.0.0-56.20200207git245fc60.fc31, guacamole-server-1.1.0-5.fc31, remmina-1.3.10-1.fc31, vinagre-3.22.0-17.fc31, weston-7.0.0-3.fc31, wlroots-0.6.0-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Stefan Assmann 2020-02-11 07:43:58 UTC
As mentioned in comment #4, the issue is not fixed.

Comment 7 Fedora Update System 2020-02-17 01:26:17 UTC
freerdp-2.0.0-56.20200207git245fc60.fc30, guacamole-server-1.1.0-5.fc30, remmina-1.3.10-1.fc30, vinagre-3.22.0-16.fc30, weston-6.0.1-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-06-30 08:53:13 UTC
FEDORA-2020-dd8c133829 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-dd8c133829

Comment 9 Fedora Update System 2020-07-01 02:09:43 UTC
FEDORA-2020-dd8c133829 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-dd8c133829`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-dd8c133829

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-07-01 02:18:56 UTC
FEDORA-2020-a3ef998a70 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a3ef998a70`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a3ef998a70

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-07-09 01:04:58 UTC
FEDORA-2020-a3ef998a70 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2020-07-09 01:06:09 UTC
FEDORA-2020-dd8c133829 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.