Bug 179724 - gthumb crashes if image directory is renamed
Summary: gthumb crashes if image directory is renamed
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Carl Worth
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-02 14:45 UTC by William Shotts
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 13:37:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description William Shotts 2006-02-02 14:45:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
If gthumb is set to return to a specific directory at start-up and the specified directory is not present at start-up gthumb crashes.

Version-Release number of selected component (if applicable):
gthumb-2.7.2-1

How reproducible:
Always

Steps to Reproduce:
1. Create a directory, for example "photos"
2. Start gthumb and select that directory.  Check preference/general/on startup go to last visited folder.
3. Quit gthumb.
4. Re-name directory to "photos1"
5. Start gthumb.
  

Actual Results:  gthumb crashes

Expected Results:  gthumb falls back to some reasonable directory like $HOME

Additional info:

Comment 1 Rahul Sundaram 2006-02-20 11:26:21 UTC

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Comment 2 William Shotts 2006-02-20 13:21:40 UTC
This issue is fixed as of version gthumb-2.7.3-1.


Note You need to log in before you can comment on or make changes to this bug.