Bug 1797274 - AttributeError: can't set attribute
Summary: AttributeError: can't set attribute
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a3844eccc2845c3aa610b12706e...
: 1797273 (view as bug list)
Depends On:
Blocks: F32BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2020-02-02 03:33 UTC by lnie
Modified: 2020-02-17 16:30 UTC (History)
10 users (show)

Fixed In Version: anaconda-32.22-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-17 16:30:07 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (910.24 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: anaconda.log (27.30 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: dbus.log (2.92 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: dnf.librepo.log (1.30 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: environ (637 bytes, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: lorax-packages.log (24.38 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: lsblk_output (1.53 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: nmcli_dev_list (1.60 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: os_info (699 bytes, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: program.log (30.00 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: storage.log (108.88 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: syslog (260.33 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details
File: packaging.log (8.97 KB, text/plain)
2020-02-02 03:34 UTC, lnie
no flags Details

Description lnie 2020-02-02 03:33:58 UTC
Description of problem:
create partitions manually(custom partition or blivet-gui)
crash will happens almost immediately after you click "Done" button

Version-Release number of selected component:
anaconda-32.21

The following was filed automatically by anaconda:
anaconda 32.21 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.8/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.8/site-packages/pyanaconda/ui/gui/spokes/custom_storage.py", line 1026, in _do_check
    self.storage.devicetree.names = self._storage_playground.devicetree.names
  File "/usr/lib64/python3.8/site-packages/pyanaconda/ui/gui/spokes/custom_storage.py", line 1087, in on_back_clicked
    if not self._do_check():
AttributeError: can't set attribute

Additional info:
addons:         com_redhat_kdump
blivet-gui-utils.log: 
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-rawh rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
hawkey.log:     INFO Feb-02 03:30:54 === Started libdnf-0.43.1 ===
kernel:         5.5.0-0.rc6.git3.1.fc32.x86_64
product:        Fedora
release:        Fedora release 32 (Rawhide)
release_type:   pre-release
type:           anaconda
version:        rawhide

Comment 1 lnie 2020-02-02 03:34:07 UTC
Created attachment 1657089 [details]
File: anaconda-tb

Comment 2 lnie 2020-02-02 03:34:10 UTC
Created attachment 1657090 [details]
File: anaconda.log

Comment 3 lnie 2020-02-02 03:34:13 UTC
Created attachment 1657091 [details]
File: dbus.log

Comment 4 lnie 2020-02-02 03:34:15 UTC
Created attachment 1657092 [details]
File: dnf.librepo.log

Comment 5 lnie 2020-02-02 03:34:17 UTC
Created attachment 1657093 [details]
File: environ

Comment 6 lnie 2020-02-02 03:34:20 UTC
Created attachment 1657094 [details]
File: lorax-packages.log

Comment 7 lnie 2020-02-02 03:34:22 UTC
Created attachment 1657095 [details]
File: lsblk_output

Comment 8 lnie 2020-02-02 03:34:23 UTC
Created attachment 1657096 [details]
File: nmcli_dev_list

Comment 9 lnie 2020-02-02 03:34:26 UTC
Created attachment 1657097 [details]
File: os_info

Comment 10 lnie 2020-02-02 03:34:28 UTC
Created attachment 1657098 [details]
File: program.log

Comment 11 lnie 2020-02-02 03:34:32 UTC
Created attachment 1657099 [details]
File: storage.log

Comment 12 lnie 2020-02-02 03:34:38 UTC
Created attachment 1657100 [details]
File: syslog

Comment 13 lnie 2020-02-02 03:34:41 UTC
Created attachment 1657101 [details]
File: packaging.log

Comment 14 lnie 2020-02-02 03:43:27 UTC
*** Bug 1797273 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Blocker Bugs Application 2020-02-02 03:43:44 UTC
Proposed as a Blocker for 32-beta by Fedora user lnie using the blocker tracking app because:

 This affects :
When using both the installer-native and the blivet-gui-based custom partitioning flow, the installer must be able to Assign sizes to newly-created storage volumes and containers

Comment 16 lnie 2020-02-02 09:32:41 UTC
I've checked with Fedora-Everything-netinst-x86_64-Rawhide-20200131.n.0.iso and Fedora-Workstation-Live-x86_64-Rawhide-20200122.n.1.iso
(can't check Fedora-Workstation-Live-x86_64-Rawhide-20200131.n.0.iso due to #1795000)

Comment 17 Vendula Poncova 2020-02-03 12:20:49 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/2303

Comment 18 Adam Williamson 2020-02-03 17:19:22 UTC
openQA is hitting this too, in just about every custom/blivet partitioning test.

Comment 19 Adam Williamson 2020-02-06 21:39:13 UTC
Discussed at 2020-02-03 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2020-02-03/f32-blocker-review.2020-02-03-17.13.html . Accepted as a violation of just about every bullet at https://fedoraproject.org/wiki/Fedora_32_Beta_Release_Criteria#Custom_partitioning .

Comment 20 Ben Cotton 2020-02-11 16:40:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 21 Adam Williamson 2020-02-17 16:30:07 UTC
This looks resolved in recent composes, to openQA at least.


Note You need to log in before you can comment on or make changes to this bug.