Bug 179739 - the pcspkr driver is disabled
the pcspkr driver is disabled
Status: CLOSED DUPLICATE of bug 160172
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-02-02 11:25 EST by Florin Andrei
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-03 15:10:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2006-02-02 11:25:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-0.fc4 Firefox/1.5

Description of problem:
This is not specific to FC5t2 but to all recent Fedora versions.

The PC speaker driver (pcspkr) is disabled. In order to enable the driver, the user must create, on all systems, the executable /etc/sysconfig/modules/pcspkr.modules with the following content:

/sbin/modprobe pcspkr

The PC speaker driver is useful, it is used by PCMCIA to signal various initialization stages, it is used by instant messaging software (gaim, xchat) and many other apps.
However, on Fedora, pcspkr is disabled and all these apps cannot function properly.
It is annoying to enable the driver manually on each and every system.

Please either include by default the pcspkr.modules file in the distribution, or compile the pcspkr driver in the kernel (not as a module).

This problem has been brought to the attention of the devel team long time ago, however nothing happened so far, although it is easy to fix and produces a significant subjective improvement in the behavior of the OS.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.see above

Actual Results:  The PC speaker driver doesn't work.

Expected Results:  The PC speaker driver should be loaded by default when the system boots up.

Additional info:
Comment 1 Dave Jones 2006-02-03 15:10:12 EST

*** This bug has been marked as a duplicate of 160172 ***

Note You need to log in before you can comment on or make changes to this bug.