Bug 17974 - xfs initscript looses user fonts.dir for true type
xfs initscript looses user fonts.dir for true type
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 16:31 EDT by Paul Flinders
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 16:27:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Flinders 2000-09-30 16:31:44 EDT
The initscript for xfs will overwrite user edits to
fonts.{dir,scale}. This seems to be rather antisocial
behaviour.

I have quite a few TrueType fonts installed (in fact
I use no bitmap fonts if I can help it). For some of the
fonts ttmfdir output is not exactly as I want - for example
it gives "Swis721 Md BT" as the name of a Bitstream
sourced Swiss721 (aka Helvetica) font - the Md is really
the weight (medium) so (IMO) souldn't be part of the familly
name - to be fair to ttmfdir I think that this is the name actually
recorded in the font.

Consequently I have a hand-tuned fonts.dir for these fonts,
unfortunately it gets overwritten every time I add a font
to the directory (which is rather annoying).
Comment 1 Mike A. Harris 2001-03-20 02:08:37 EST
This seems to be the intended behaviour of the ttmkfdir program.  I
do not see it as a problem.  The author of the program will have
to change the behaviour if it is to be changed at all.

Note You need to log in before you can comment on or make changes to this bug.