Bug 1797491 - Drop etcd deprecated metrics from Prometheus
Summary: Drop etcd deprecated metrics from Prometheus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Lili Cosic
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 09:48 UTC by Lili Cosic
Modified: 2020-05-04 11:28 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:28:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 72 0 None closed Bug 1797491: manifests: Drop Deprecated etcd metrics 2020-04-20 10:01:25 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:28:59 UTC

Description Lili Cosic 2020-02-03 09:48:55 UTC
Description of problem:
Initial dropping of deprecated metrics missed etcd, as they have moved their ServiceMonitor file in their operator repo.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open Prometheus and search for any fo the following metrics:
etcd_(helper_cache_hit_count|helper_cache_miss_count|helper_cache_entry_count|request_cache_get_latencies_summary|request_cache_add_latencies_summary|request_latencies_summary)


Expected results:

We want to drop those metrics, so we should not see any when querying in Prometheus

Comment 3 Junqi Zhao 2020-02-06 02:56:23 UTC
tested with 4.4.0-0.nightly-2020-02-05-181112
etcd_(helper_cache_hit_count|helper_cache_miss_count|helper_cache_entry_count|request_cache_get_latencies_summary|request_cache_add_latencies_summary|request_latencies_summary) are dropped, and can not find from Prometheus

# oc -n openshift-etcd-operator get servicemonitor/etcd-operator -oyaml
apiVersion: monitoring.coreos.com/v1
kind: ServiceMonitor
metadata:
  creationTimestamp: "2020-02-05T23:29:05Z"
  generation: 1
  name: etcd-operator
  namespace: openshift-etcd-operator
  resourceVersion: "12648"
  selfLink: /apis/monitoring.coreos.com/v1/namespaces/openshift-etcd-operator/servicemonitors/etcd-operator
  uid: f6c13d2b-425f-46b6-aa6e-be0bd2de855e
spec:
  endpoints:
  - bearerTokenFile: /var/run/secrets/kubernetes.io/serviceaccount/token
    interval: 30s
    metricRelabelings:
    - action: drop
      regex: etcd_(debugging|disk|request|server).*
      sourceLabels:
      - __name__
    - action: drop
      regex: etcd_(helper_cache_hit_count|helper_cache_miss_count|helper_cache_entry_count|request_cache_get_latencies_summary|request_cache_add_latencies_summary|request_latencies_summary)
      sourceLabels:
      - __name__
    port: https
    scheme: https
    tlsConfig:
      caFile: /etc/prometheus/configmaps/serving-certs-ca-bundle/service-ca.crt
      serverName: metrics.openshift-etcd-operator.svc
  jobLabel: component
  namespaceSelector:
    matchNames:
    - openshift-etcd-operator
  selector:
    matchLabels:
      app: etcd-operator

Comment 4 Lili Cosic 2020-04-20 10:02:05 UTC
This is already in the release notes.

Comment 6 errata-xmlrpc 2020-05-04 11:28:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.