Bug 1797501 - Cannot choose flexible osd size in install and expand
Summary: Cannot choose flexible osd size in install and expand
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: ---
: 4.3.z
Assignee: afrahman
QA Contact: Harish NV Rao
URL:
Whiteboard:
Depends On: 1796812
Blocks: 1795680
TreeView+ depends on / blocked
 
Reported: 2020-02-03 10:02 UTC by afrahman
Modified: 2020-04-01 19:12 UTC (History)
9 users (show)

Fixed In Version: 4.3.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1796812
Environment:
Last Closed: 2020-04-01 19:10:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
drop-down options (97.47 KB, image/jpeg)
2020-03-18 11:56 UTC, Harish NV Rao
no flags Details
ocp version (51.23 KB, image/jpeg)
2020-03-18 11:57 UTC, Harish NV Rao
no flags Details
ocs version (62.86 KB, image/jpeg)
2020-03-18 11:58 UTC, Harish NV Rao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4149 0 None closed [release-4.3] Bug 1797501: Adds flexible OSD Sizes in the install flow 2020-03-26 10:38:27 UTC
Red Hat Product Errata RHBA-2020:0930 0 None None None 2020-04-01 19:12:20 UTC

Description afrahman 2020-02-03 10:02:30 UTC
+++ This bug was initially created as a clone of Bug #1796812 +++

Description of problem:

Cannot choose flexible osd size in install and expand

Version-Release number of selected component (if applicable):

OCP 4.3+

How reproducible:

After installing RHOCS , follow these steps:

Installed operators -> Openshift Container storage -> Create storage cluster -> No option to set flexible osd size

Steps to Reproduce:
1. Go to Installed operators
2. Select Openshift Container storage
3. Select Create storage cluster

Actual results:

There should be an option to select flexible osd sizes

Expected results:

The option is missing

Additional info:

Comment 1 Harish NV Rao 2020-03-18 10:15:53 UTC
@afreen, can you please fill "fixed in version" field of this bug? I want to know which ocp version to use for testing the fix.

Comment 2 afrahman 2020-03-18 10:53:17 UTC
https://openshift-release.svc.ci.openshift.org/releasestream/4-stable/release/4.3.2

This is the version that has the fix, Builds after that would be eligible too for testing.

Updated the the "fixed in version field".

Comment 3 afrahman 2020-03-18 11:10:38 UTC
https://openshift-release.svc.ci.openshift.org/releasestream/4-stable/release/4.3.2

This is the version that has the fix, Builds after that would be eligible too for testing.

Updated the the "fixed in version field".

Comment 4 Harish NV Rao 2020-03-18 11:54:06 UTC
Thanks Afreen!

Verified this BZ on OCP 4.3.5 with OCS 4.3.0-376.ci on chrome and firefox. 

"Installed operators -> Openshift Container storage -> Create storage cluster" now shows drop-down menu with options for selecting 0.5 TiB, 2 TiB and 4 TiB.

attached are the screenshots

Comment 5 Harish NV Rao 2020-03-18 11:56:57 UTC
Created attachment 1671028 [details]
drop-down options

Comment 6 Harish NV Rao 2020-03-18 11:57:53 UTC
Created attachment 1671029 [details]
ocp version

Comment 7 Harish NV Rao 2020-03-18 11:58:51 UTC
Created attachment 1671030 [details]
ocs version

Comment 13 afrahman 2020-03-24 04:07:00 UTC
@Bipin Kunal I think the steps are already taken for this by doc team.

@Kenneth Hartsoe looping you in ^^

Comment 14 afrahman 2020-03-25 09:08:12 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1797977 documentation bug for the feature

Comment 17 errata-xmlrpc 2020-04-01 19:10:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0930


Note You need to log in before you can comment on or make changes to this bug.