This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 179756 - display IP address when asking vnc client viewer which hostname to connect
display IP address when asking vnc client viewer which hostname to connect
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 12:49 EST by magaoaye
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 19:02:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description magaoaye 2006-02-02 12:49:57 EST
Description of problem:

During VNC based install, the server (installing system) would ask the client
viewer which "hostname:<display#>" to connect without including its IP address.
The client viewer will not be able to connect simply by using
hostname:<display#> without any naming service running (local DNS), that
resolved hostname to IP address. 

Version-Release number of selected component (if applicable):
anaconda-10.91.11-1

How reproducible:
Always

Steps to Reproduce:

1. Using kickstart config file setup the following:
   ks.cfg:  vnc
            url --url ftp://192.168.3.30/mysrc/fed/x86_64
            network --bootproto dhcp --hostname bahamas2
   Assumption: client viewer has the source tree and kickstart file
               IP address: 192.168.3.30
               kickstart: /mysrc/vnc/ks.cfg

2. During kernel boot-time prompt, type:
       linux ks=ftp://192.168.3.30/mysrc/vnc/ks.cfg

3. Wait until the installation has properly setup the VNC server and ask you to
connect from the VNC client viewer.

==================================
11:42:07 INFO    : The VNC server is now running.
11:42:07 INFO    : Please connect to bahamas2:1 to begin the install...
=================================

4. Assuming that there is no local DNS running, from the client viewer type:
     vncviewer bahamas2:1

Actual results: The output will show
=================================
 unable to resolve host by name: Success (0)
=================================

Expected results:

The last line should at least identify the IP address rather than just the
hostname i.e:
=================================
11:42:07 INFO    : Please connect to 192.168.3.32:1 (bahamas2:1) to begin the
install...
=================================

So when you execute from the VNC client viewer:

    vncviewer 192.168.3.32:1  (assumed 192.168.3.32=>bahamas2)

Connection will succeed and allow the installation to proceed!

Additional info:
Comment 1 Jeremy Katz 2006-02-03 19:02:15 EST
You only get a hostname if a reverse lookup works.  If your environment doesn't
have consistent DNS, then it is broken.
Comment 2 magaoaye 2006-02-03 20:47:46 EST
I don't think anaconda is verifying whether DNS is working before displaying the
hostname in place of IP addr. Anaconda mistakenly think DNS is working if you
defined the hostname in the kickstart file; thus, prompting you to connect to a
hostname instead of IP addr. Remember, you can't set up the proper environment
ahead of time for the client viewer to map hostname to IP address if the
installing system uses DHCP.

I think the quick fix would be to always display the IP address regardless of
whether the hostname is defined or not.  This is easy since the installing
system always knows what IP address it has been assigned from DHCP. Otherwise,
the user will have to dig into /tmp/syslog or ping the available address space
which is cumbersome and time consuming.

eric

Note You need to log in before you can comment on or make changes to this bug.