Bug 1797586 - Service binding in Operator backed service is not working in topology
Summary: Service binding in Operator backed service is not working in topology
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 13:00 UTC by Karthik Jeeyar
Modified: 2020-05-04 11:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Operator backed service does not have capability to bind to a service Consequence: Service binding is not possible for a operator backed service. Fix: Add service binding capability to the Operator backed services in the topology. Result: User can now bind the OBS nodes to a service.
Clone Of:
Environment:
Last Closed: 2020-05-04 11:29:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Not able to bind a workload with an Operator Backed Service (1.10 MB, image/gif)
2020-02-03 13:00 UTC, Karthik Jeeyar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4153 0 None closed BUG 1797586: fix(operator-binding) - add operator backed service binding 2020-04-20 10:09:39 UTC

Description Karthik Jeeyar 2020-02-03 13:00:56 UTC
Created attachment 1657349 [details]
Not able to bind a workload with an Operator Backed Service

Description of problem:

Workload Edge is no more dropable in Operator backed workload to create Service binding request. Currently it show Plus icon when hovered over operator backed service

Version-Release number of selected component (if applicable):

4.4 


Steps to Reproduce:
1. Drag and try to drop an edge in topology from other workload to operator workload


Actual results:
Operator workload is not dropable.

Expected results:

User should be able to drop an edge on operator workload to create binding/visual connectors to it.

Comment 2 Ruchir Garg 2020-03-02 06:38:37 UTC
Bulk assigning all to Gajanan for verification.

Comment 3 Gajanan More 2020-03-02 11:36:21 UTC
https://issues.redhat.com/browse/ODC-2923 verified by Vikram Raj

Comment 5 errata-xmlrpc 2020-05-04 11:29:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.