Bug 179759 - Ant should provide $ANT_HOME/lib/ant.jar
Ant should provide $ANT_HOME/lib/ant.jar
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Permaine Cheung
Fedora Extras Quality Assurance
http://emma.sourceforge.net
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 13:06 EST by Ian Pilcher
Modified: 2009-08-07 18:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 18:24:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to ant.spec to provide symbolic links to jar files in $ANT_HOME (7.83 KB, patch)
2009-07-17 18:57 EDT, Orion Poplawski
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
JPackage 196 None None None Never

  None (edit)
Description Ian Pilcher 2006-02-02 13:06:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Some programs ignore the current CLASSPATH and expect to find ant.jar in
$ANT_HOME/lib/ant.jar.  (The EMMA build script is an example.)  Since this is
the layout used in binary distributions of Ant, this doesn't seem entirely
unreasonable.

It should be simple to provide a symlink from /usr/share/ant/lib/ant.jar to
/usr/share/java/ant.jar.

Version-Release number of selected component (if applicable):
ant-1.6.5-1jpp_4fc

How reproducible:
Always

Steps to Reproduce:
1.  Download EMMA source code from above URL.
2.  Create build.properties with Ant directory set to /usr/share/ant.
3.  Run "ant" to build EMMA.
  

Actual Results:  Build fails; unable to resolve Ant classes.

Expected Results:  Build should succeed.

Additional info:

I have also entered this in JPackage's Bugzilla as bug #196.
Comment 1 Deepak Bhole 2006-06-08 13:20:51 EDT
/usr/share/java/ant is not meant to be ANT_HOME. The suggested (JPackage style)
workaround for this is setting ant dir to something else, creating a lib/ in
there, and using build-jar-repository to link the appropriate jars.
Comment 2 Bug Zapper 2008-04-03 12:52:22 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 3 Bug Zapper 2008-05-06 20:21:00 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp
Comment 4 Orion Poplawski 2008-11-12 10:55:20 EST
${ant.home} is now /usr/share/ant, which is appropriate.  But many projects expect ${ant.home}/lib/ant.jar to exist as in the binary distribution (I'm seeing it in gridengine's sdm module).  Please provide symlinks to the jar files in ${ant.home}/lib/.
Comment 5 Bug Zapper 2008-11-25 20:48:27 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Orion Poplawski 2009-07-17 18:57:18 EDT
Created attachment 354235 [details]
Patch to ant.spec to provide symbolic links to jar files in $ANT_HOME

Ping, hello?  Still an issue with F-11.

I have an updated spec file ready to go for this.  Successful koji test build here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1483273

I can check it in and build if that is okay.
Comment 7 Orion Poplawski 2009-08-07 18:24:12 EDT
Fixed in 1.7.1-11.fc12.

Note You need to log in before you can comment on or make changes to this bug.