Bug 1797595 (CVE-2020-7247) - CVE-2020-7247 opensmtpd: arbitrary commands execution in smtp_mailaddr in smtp_session.c via crafted SMTP session
Summary: CVE-2020-7247 opensmtpd: arbitrary commands execution in smtp_mailaddr in smt...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2020-7247
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1797596 1797597
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 13:34 UTC by Dhananjay Arunesh
Modified: 2020-02-03 14:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-03 14:09:36 UTC


Attachments (Terms of Use)

Description Dhananjay Arunesh 2020-02-03 13:34:38 UTC
A vulnerability was found in smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other products, allows remote attackers to execute arbitrary commands as root via a crafted SMTP session, as demonstrated by shell metacharacters in a MAIL FROM field. This affects the "uncommented" default configuration. The issue exists because of an incorrect return value upon failure of input validation.

Reference:
https://seclists.org/fulldisclosure/2020/Jan/49
https://www.openwall.com/lists/oss-security/2020/01/28/3
https://github.com/openbsd/src/commit/9dcfda045474d8903224d175907bfc29761dcb45

Comment 1 Dhananjay Arunesh 2020-02-03 13:35:57 UTC
Created opensmtpd tracking bugs for this issue:

Affects: epel-all [bug 1797597]
Affects: fedora-all [bug 1797596]

Comment 2 Product Security DevOps Team 2020-02-03 14:09:36 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.