Bug 17976 - IOError: [Errno 2] No such file or directory: '/mnt/sysimage/tmp/upgrade.log'
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/tmp/upgrade.log'
Status: CLOSED DUPLICATE of bug 13071
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 16:42 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 18:38:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-30 16:42:02 EDT
upgrade from 6.1:  Linux  2.2.12-20 #1 Mon Sep 27 10:40:35 EDT 1999 i686
unknown
to 7. using boot.img diskette + RH7 CD.
--------------------------------------------------------------

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1526, in
doInstall
    self.instLog = open(self.instLogName, "w+")
IOError: [Errno 2] No such file or directory:
'/mnt/sysimage/tmp/upgrade.log'

Local variables in innermost frame:
arch: i386
total: 414
msg: File exists
logname: /tmp/upgrade.log
i: /etc/X11
p: zlib-devel
l: [anacron, apache, apmd, ash, aspell, aspell-de, at, audiofile,
audiofile-devel, aumix, authconfig, autoconf, automake, awesfx, basesystem,
bash, bc, bdflush, bind, bind-utils, binutils, bison, byacc, bzip2,
bzip2-devel, cdecl, cdp, chkconfig, chkfontpath, compat-egcs,
compat-egcs-c++, compat-glibc, compat-libstdc++, console-tools,
control-center, control-panel, cpio, cpp, cproto, cracklib, cracklib-dicts,
crontabs, ctags, cvs, cyrus-sasl, db1, db1-devel, db2, db3, dev, dev86,
dhcpcd, dialog, diffstat, diffutils, dip, e2fsprogs, ed, ee, eject,
ElectricFence, elm, emacs, emacs-X11, esound, esound-devel, exmh, expect,
extace, fetchmail, file, filesystem, fileutils, findutils, finger,
finger-server, flex, fortune-mod, freetype, ftp, gawk, gcc, gcc-c++,
gcc-g77, gcc-objc, gd, gd-devel, gdb, gdbm, gdbm-devel, gdk-pixbuf, gdm,
gedit, gettext, gftp, ghostscript, ghostscript-fonts, gimp, gimp-devel,
glib, glib-devel, glibc, glibc-devel, gmc, gmp, gnome-applets, gnome-audio,
gnome-core, gnome-core-devel, gnome-games, gnome-games-devel, gnome-libs,
gnome-libs-devel, gnome-linuxconf, gnome-media, gnome-objc,
gnome-objc-devel, gnome-pim, gnome-pim-devel, gnome-print,
gnome-users-guide, gnome-utils, gnorpm, gnotepad+, gnuchess, gnumeric,
gnupg, gnuplot, gpm, gpm-devel, gqview, grep, groff, groff-perl, gtk+,
gtk+-devel, gtk-engines, gtop, guile, gv, gzip, hdparm, ical, ImageMagick,
imlib, imlib-cfgeditor, imlib-devel, indent, indexhtml, inews, info,
initscripts, iputils, isapnptools, isdn4k-utils, kbdconfig, kdebase,
kdegames, kdegraphics, kdelibs, kdelibs-devel, kdemultimedia, kdenetwork,
kdesupport, kdesupport-devel, kdetoys, kdeutils, kernel, kernel-headers,
kernel-pcmcia-cs, kernel-source, kernel-utils, kernelcfg, kgcc, kpppload,
krb5-libs, kudzu, less, libghttp, libglade, libgtop, libjpeg,
libjpeg-devel, libpng, libpng-devel, librep, libstdc++, libstdc++-devel,
libtermcap, libtermcap-devel, libtiff, libtiff-devel, libtool-libs,
libungif, libungif-devel, libxml, libxml-devel, lilo, linuxconf,
linuxconf-devel, logrotate, losetup, LPRng, lrzsz, lynx, m4, magicdev,
mailcap, mailx, make, MAKEDEV, man, man-pages, mc, Mesa, metamail, mikmod,
mingetty, minicom, mkbootdisk, mkinitrd, mktemp, mkxauth, modemtool,
modutils, mount, mouseconfig, mpage, mt-st, multimedia, mutt, ncftp,
ncompress, ncurses, ncurses-devel, ncurses4, net-tools, netcfg, netpbm,
netpbm-devel, netpbm-progs, netscape-common, netscape-communicator, newt,
newt-devel, nfs-utils, nmh, ntsysv, openjade, openldap, openssl, ORBit,
ORBit-devel, pam, passwd, patch, pciutils, perl, pine, playmidi,
playmidi-X11, pmake, popt, portmap, postgresql, postgresql-devel,
postgresql-server, ppp, printtool, procmail, procps, psmisc, pspell, pump,
pwdb, pygnome-libglade, pygtk-libglade, python, pythonlib, qt, qt1x,
qt1x-devel, quota, raidtools, rcs, rdate, rdist, readline, readline-devel,
redhat-logos, redhat-release, rep-gtk, rep-gtk-gnome, rhs-printfilters,
rmt, rootfiles, rp3, rpm, rpm-build, rpm-devel, rpm-python, rsh,
rsh-server, rusers, rusers-server, rwho, rxvt, sash, sawfish, sed,
sendmail, setserial, setup, setuptool, sgml-common, sgml-tools, sh-utils,
shadow-utils, sharutils, slang, slang-devel, slocate, slrn, sndconfig, sox,
stat, statserial, strace, switchdesk, switchdesk-gnome, sysklogd, SysVinit,
talk, talk-server, tar, tcl, tclx, tcp_wrappers, tcpdump, tcsh, telnet,
telnet-server, termcap, tetex, tetex-fonts, tetex-xdvi, texinfo, textutils,
tftp-server, time, timeconfig, timetool, tin, tix, tk, tkinter, tksysv,
tmpwatch, traceroute, trn, umb-scheme, unzip, urlview, urw-fonts, usermode,
utempter, util-linux, vim-common, vim-minimal, vixie-cron, which, whois,
words, wvdial, Xaw3d, Xaw3d-devel, xboard, xchat, Xconfigurator, XFree86,
XFree86-3DLabs, XFree86-75dpi-fonts, XFree86-8514, XFree86-AGX,
XFree86-devel, XFree86-doc, XFree86-FBDev, XFree86-I128, XFree86-libs,
XFree86-Mach32, XFree86-Mach64, XFree86-Mach8, XFree86-Mono, XFree86-P9000,
XFree86-tools, XFree86-twm, XFree86-VGA16, XFree86-xdm, XFree86-xf86cfg,
XFree86-xfs, xinetd, xinitrc, xloadimage, xmailbox, xpaint, xrn,
xscreensaver, xsri, xxgdb, yp-tools, ypbind, zip, zlib, zlib-devel]
db: <rpmdb object at 895efd0>
self: <todo.ToDo instance at 827c7b0>
how: u
errno: 17
totalSize: 1014632
f: <closed file '/mnt/sysimage/etc/mtab', mode 'w+' at 8f72de8>
ts: <rpmtrans object at 897aef8>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>
Comment 1 Need Real Name 2000-10-01 17:58:00 EDT
fixed problem; /tmp cannot be a soft link.
Comment 2 Michael Fulbright 2000-10-02 18:38:40 EDT

*** This bug has been marked as a duplicate of 13071 ***

Note You need to log in before you can comment on or make changes to this bug.