Bug 1797643 - Set shorter names when generating pipeline on import flows
Summary: Set shorter names when generating pipeline on import flows
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Rohit Rai
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 14:39 UTC by Rohit Rai
Modified: 2020-05-13 21:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:58:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Shorter names when generating pipeline on import flows (64.81 KB, image/png)
2020-03-05 13:23 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4179 None closed Bug 1797643: Set shorter names when generating pipeline on import flows 2020-05-01 22:04:39 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:58:37 UTC

Description Rohit Rai 2020-02-03 14:39:09 UTC
Description of problem:

When one checks the "Add pipeline" checkbox on import flows, the pipeline name is set as app-name + pipeline-template-name which leads to very long names: openshift-quickstarts-s2i-java-11-build-and-deploy-pipeline




Version-Release number of selected component (if applicable): 4.4


How reproducible:


Steps to Reproduce:
1. Go to import flow. Select `Add pipeline` option from `pipelines Section` 
2. Create the application.


Actual results:
- The pipeline that gets created has a long name with `app name` and `pipeline-template-name`

Expected results:

- Should use the `app name` for the Pipeline that is created
- It shouldn't be able to submit without the pipeline being created, ie it should get a similar error on submit:

Comment 3 Andrew Ballantyne 2020-02-07 16:38:36 UTC
@Rohit I've changed this to be assigned to you, please update the doc text.

Comment 4 spathak@redhat.com 2020-03-05 13:23:04 UTC
Created attachment 1667750 [details]
Shorter names when generating pipeline on import flows

Comment 5 spathak@redhat.com 2020-03-05 13:24:11 UTC
Verified on build : 4.4.0-0.nightly-2020-03-05-014624
Chrome browser: 76.0.3809.132

Comment 7 errata-xmlrpc 2020-05-13 21:58:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.