Bug 1797675 - Makefile general e2e test targets need to avoid rh-operator metric tests
Summary: Makefile general e2e test targets need to avoid rh-operator metric tests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.4.0
Assignee: Bowen Song
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 16:00 UTC by Bowen Song
Modified: 2020-05-13 21:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:58:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1274 None closed Bug 1797675: Refactoring rh-operator test directory 2020-04-29 09:16:16 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:58:41 UTC

Description Bowen Song 2020-02-03 16:00:25 UTC
Description of problem:
The OLM e2e test does not require to run the rh-operator metric cardinality tests. All Makefile targets should avoid test/e2e/rh-operators/ directory. Currently only make e2e avoids it.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Steps to Reproduce:
1.make run-local
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Bruno Andrade 2020-02-05 20:42:20 UTC
Ran `make run-local` at operator-lifecycle-manager and it does not trigger rh-operator tests as expected. Marking as VERIFIED

Comment 5 errata-xmlrpc 2020-05-13 21:58:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.