Bug 179768 - system-config-httpd uses obsolete SSL configuration defaults
system-config-httpd uses obsolete SSL configuration defaults
Status: CLOSED DUPLICATE of bug 169620
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-02 13:48 EST by Mike Jang
Modified: 2015-03-04 20:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-28 05:20:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Jang 2006-02-02 13:48:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
When configuring Virtual Hosts, the SSL properties use obsolete dummy certificate files:

/etc/httpd/conf/ssl.crt/server.crt
/etc/httpd/conf/ssl.key/server.key
/etc/httpd/conf/ssl.crt/ca.crt
/etc/httpd/conf/ssl.crt/ca-bundle.crt

These used to be installed through the mod_ssl package, but that was recently changed.

Version-Release number of selected component (if applicable):
system-config-httpd-1.3.3-1.1

How reproducible:
Always

Steps to Reproduce:
1.Open system-config-httpd
2.Select Virtual Hosts tab
3.Click Add or Edit to open the Virtual Host Properties window
4.Select the SSL tab
  

Actual Results:  The SSL tab displays the obsolete keys

Expected Results:  The SSL Configuration file text boxes should either be blank - or should point to new defaults in /etc/pki/tls. If you want to continue using defaults, new files should be added to mod_ssl.

Additional info:

Seems closely related to 169620, but that bug doesn't address these files.
Comment 1 Rahul Sundaram 2006-02-20 06:01:03 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Phil Knirsch 2006-06-28 05:20:13 EDT

*** This bug has been marked as a duplicate of 169620 ***

Note You need to log in before you can comment on or make changes to this bug.